Ticket #4363: OptionalPackages5.diff

File OptionalPackages5.diff, 1.6 KB (added by scottmc, 11 years ago)

patch to update Pe and subversion to use 2009-09-02 builds

  • build/jam/OptionalPackageDependencies

     
    44# dependencies.
    55
    66OptionalPackageDependencies Subversion : APR-util Neon LibIconv LibXML2 OpenSSL SQLite ;
    7 OptionalPackageDependencies APR-util : APR ;
     7OptionalPackageDependencies APR-util : APR Expat ;
    88OptionalPackageDependencies BeHappy : BeBook NetSurf ;
    99OptionalPackageDependencies Development : DevelopmentBase Perl ;
    1010OptionalPackageDependencies DevelopmentBase : CDRecord DevelopmentMin Yasm ;
  • build/jam/OptionalPackages

     
    684684                : $(baseURL)/Pe-2.4.2-x86-gcc4-2009-08-04.zip
    685685            ;
    686686        } else {
    687             InstallOptionalHaikuImagePackage Pe-2.4.2-x86-gcc2-2009-07-05
    688                 : $(baseURL)/Pe-2.4.2-x86-gcc2-2009-07-05.zip
     687            InstallOptionalHaikuImagePackage Pe-2.4.2-r593-r1a1-x86-gcc2-2009-09-02
     688                : $(baseURL)/Pe-2.4.2-r593-r1a1-x86-gcc2-2009-09-02.zip
    689689            ;
    690690        }
    691691
     
    755755    if $(TARGET_ARCH) != x86 {
    756756        Echo "No optional package Subversion available for $(TARGET_ARCH)" ;
    757757    } else {
    758         InstallOptionalHaikuImagePackage subversion-1.6.5-r1a1-x86-gcc2-2009-08-30
    759             : $(baseURL)/subversion-1.6.5-r1a1-x86-gcc2-2009-08-30.zip
     758        InstallOptionalHaikuImagePackage subversion-1.6.5-r1a1-x86-gcc2-2009-09-02
     759            : $(baseURL)/subversion-1.6.5-r1a1-x86-gcc2-2009-09-02.zip
    760760            :
    761761        ;
    762762    }