Opened 6 years ago

Last modified 6 years ago

#10208 new bug

Drivesetup creating partition size errors — at Initial Version

Reported by: PieterPanman Owned by: bonefish
Priority: high Milestone: R1
Component: Partitioning Systems Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've taken hrev46368 (x86_gcc) for a spin and decided to install it into my main machine on a spare drive. It is a ST9320423AS, Seagate Momentus 7200.4 ST9320423AS 320GB 7200 RPM 16MB. I decided to have 2 haiku OS partitions and 1 haiku data partition. Steps: 1) boot from USB stick 2) Fire up DriveSetup 3) Initialize Disk to Intel Partition Map (it was unrecognized for some reason, but I can't remember what OS was on it...) 4) Add 3 partitions

  • Haiku32 (about 20 GiB, using the slider)
  • Haiku64 (about 30 GiB, using the slider)
  • HaikuData (the rest of the available space)

5) Format Haiku32 6) Install haiku to Haiku32 using HaikuInstaller 7) Reboot 8) Start Haiku from USB stick into boot menu, I can't find Haiku32... 9) Back into Haiku (usb stick), the partition sizes are now approximately 3, 4 and 67 GiB! 10) Reinstall Haiku unto Haiku32 11) Now Haiku32 is visible in my boot menu on the USB stick.

It is almost as if performing these actions in 1 go (initialize, create x3, format, install), it has miscounted the sizes. The actual written partition map sizes after the reboot is pretty much 4x smaller, but before the reboot its idea of the partition map is the originally intended sizes. I'll see if I can gather some useful information

Change History (2)

by PieterPanman, 6 years ago

Attachment: syslog added

by PieterPanman, 6 years ago

Attachment: listdev.txt added
Note: See TracTickets for help on using tickets.