Opened 5 years ago

Closed 5 years ago

#11068 closed bug (fixed)

Setting up framebuffer raises a floating point exception

Reported by: arvindsraj Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/Development
Keywords: gsoc2014 Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: arm

Description

When trying to setup the framebuffer, a floating point exception is raised. The fault is actually when a value is written to CM_CLKSEL_DSS. For now, the process has been disabled by setting gFramebuffer to NULL and a TODO has been included.

Attachments (2)

Disable-frame-buffer-for-now.patch (1.3 KB ) - added by arvindsraj 5 years ago.
Disable-frame-buffer-for-now-2.patch (1.4 KB ) - added by arvindsraj 5 years ago.

Download all attachments as: .zip

Change History (9)

by arvindsraj, 5 years ago

comment:1 by arvindsraj, 5 years ago

Has a Patch: set

comment:2 by anevilyak, 5 years ago

Component: - GeneralSystem/Boot Loader
Owner: changed from nobody to axeld

comment:3 by arvindsraj, 5 years ago

Modified the patch. Here's a description of the changes made.

  • The comment is more verbose than before - it also mentions the specific commit of the qemu-linaro from git at which this was tested.
  • The commented code now uses FB_BASE instead of harcoding it's value.

by arvindsraj, 5 years ago

comment:4 by pulkomandy, 5 years ago

Resolution: fixed
Status: newclosed

Applied in hrev47590.

Version 0, edited 5 years ago by pulkomandy (next)

comment:5 by pulkomandy, 5 years ago

Resolution: fixed
Status: closedreopened

comment:6 by ithamar, 5 years ago

This isn't an issue with the code, the issue is that we are trying to use OMAP3 code on an AM37x SoC. The LCD controller is not the same, just like another long list of peripherals. The problem is that the original target was the original BeagleBoard, while we are now testing it on QEMU using the BeagleBoard-xM target (which has a different SoC).

comment:7 by pulkomandy, 5 years ago

Resolution: fixed
Status: reopenedclosed

This was fixed during the coding sprint. It works now!

Note: See TracTickets for help on using tickets.