Opened 2 years ago

Closed 2 years ago

#13204 closed bug (invalid)

[MP3 Attributes] (AP) shows right file info. Just (A) wrong. Also No sound

Reported by: Morbid Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Attributes MP3 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

MP3-Files with the attributes (AP) will be shown correct in File-Info as MP3. Files with attribute (A) doesn't. Also no Sound on playing Files 04 & 09 but it's maybe another ticket.

Attachments (9)

Mediaplayer1.jpg (229.8 KB) - added by Morbid 2 years ago.
Listdev.txt (3.7 KB) - added by Morbid 2 years ago.
Attrib_04&09_normal_speed.jpg (63.4 KB) - added by Morbid 2 years ago.
Attrib_06_fast.jpg (67.4 KB) - added by Morbid 2 years ago.
devices.jpeg (154.2 KB) - added by Morbid 2 years ago.
Song04_attrib_AP.jpeg (131.6 KB) - added by Morbid 2 years ago.
Song04_attrib_AP.avi (579.1 KB) - added by Morbid 2 years ago.
06-Blues Pills_attrib_A.avi (188.7 KB) - added by Morbid 2 years ago.
Blues Pills_No Hope_320k_CUT.mp3 (1.8 MB) - added by Morbid 2 years ago.

Change History (13)

Changed 2 years ago by Morbid

Attachment: Mediaplayer1.jpg added

Changed 2 years ago by Morbid

Attachment: Listdev.txt added

Changed 2 years ago by Morbid

Changed 2 years ago by Morbid

Attachment: Attrib_06_fast.jpg added

Changed 2 years ago by Morbid

Attachment: devices.jpeg added

comment:1 Changed 2 years ago by humdinger

Apparently the "P" attribute identifies a "sparse file". It's apparently some NTFS compression scheme, see this MSDN page. I suspect out NTFS filesystem doesn't deal correctly with those?

Version 0, edited 2 years ago by humdinger (next)

comment:2 Changed 2 years ago by Morbid

But MP3 with attributes (AP) seems to play correctly. I expect why there's no sound is caused by Ticket #13203.

Changed 2 years ago by Morbid

Attachment: Song04_attrib_AP.jpeg added

Changed 2 years ago by Morbid

Attachment: Song04_attrib_AP.avi added

Changed 2 years ago by Morbid

Attachment: 06-Blues Pills_attrib_A.avi added

comment:3 Changed 2 years ago by Morbid

Did a cut with Audacity and it seems to work. This is not a problem in Haiku. Put that file for testing purpose on the server (1.8MB). Ticket could be closed. Thanks.

Changed 2 years ago by Morbid

comment:4 Changed 2 years ago by humdinger

Resolution: invalid
Status: newclosed

Thanks for investigating!

Note: See TracTickets for help on using tickets.