Opened 10 years ago

Closed 8 years ago

#4315 closed bug (fixed)

PS/2 mouse and keyboard won't work on HP530 laptop

Reported by: BePhantom Owned by: siarzhuk
Priority: high Milestone: R1/beta1
Component: Drivers/Keyboard/PS2 Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have an HP530 laptop, my touchpad and my keyboard don't work in Haiku, both are internally attached and use ps/2 interface. In windows they are configured as "generic ps/2 mouse" and "generic ps/2 keyboard". I can't find any trace of them in linux lshw. I attach the syslog.

Attachments (4)

syslog.txt (87.8 KB ) - added by BePhantom 10 years ago.
syslog-HP530-r36511 (151.8 KB ) - added by sotrud_nik 10 years ago.
syslog.dbg.HP530-2.txt (130.7 KB ) - added by sotrud_nik 10 years ago.
TRACE enabled for PS/2
syslog.dbg.HP530-5.txt (291.0 KB ) - added by sotrud_nik 10 years ago.
Tried so steps from http://dev.haiku-os.org/ticket/951, kbd worked

Download all attachments as: .zip

Change History (23)

by BePhantom, 10 years ago

Attachment: syslog.txt added

comment:1 by BePhantom, 10 years ago

Summary: PS/2 Mouse and Keyboard Won't work on HP530 laptopPS/2 mouse and keyboard won't work on HP530 laptop

comment:2 by umccullough, 10 years ago

Component: DriversDrivers/Keyboard/PS2
Owner: changed from axeld to marcusoverhagen
Type: enhancementbug

Changing component to something that seems relevant, also marking as a bug as I can't imagine why this would be an enhancement.

comment:3 by BePhantom, 10 years ago

I forgot to mention that I used haiku-pre-alpha-gcc4-hrev32591 image.

comment:4 by sotrud_nik, 10 years ago

Cc: baurthefirst@… added

Hi all!

Same there, problem isn't solved. I am using latest haiku-r1a2-rc-hrev36511-x86gcc2hybrid-anyboot build. Laptop HP530, Keyboard and Touchpad won't. External USB Mouse works fine there.

Keyboard LED (Caps Lock) blinks sometimes, about once in 5 mins. Syslog's output will be attached soon.

comment:5 by sotrud_nik, 10 years ago

Cc: baurthefirst@… removed
Milestone: R1R1/alpha2
Version: R1/pre-alpha1

by sotrud_nik, 10 years ago

Attachment: syslog-HP530-r36511 added

comment:6 by sotrud_nik, 10 years ago

syslog-HP530-hrev36511 attached.

Continue describing. As I said before, keyboard and mouse won't work after boot. If I reboot laptop, it starts working too slow, even GRUB2 menu appears after a while (20-30 sec), but usually it takes max 5-10 sec. In GRUB2 menu keyboard STILL won't work! Only reattaching laptop's battery helped me.

comment:7 by sotrud_nik, 10 years ago

http://pastie.org/939592

This is an sample from syslog file. It happens, when I pressed any key on laptop's keyboard, which doesn't work at the moment. Some new strings in syslog file appears, then Caps Lock LED blinks once, then nothing.

If any additional information required, feel free to ask.

by sotrud_nik, 10 years ago

Attachment: syslog.dbg.HP530-2.txt added

TRACE enabled for PS/2

comment:8 by sotrud_nik, 10 years ago

I searched a little, then http://dev.haiku-os.org/ticket/951 found.

So, I reproduced following steps: 1)In file src/add-ons/kernel/bus_managers/ps2/ps2_common.c, function ps2_setup_active_multiplexing, I inserted ps2_command(0x93, (const uint8 *)"", 1, NULL, 0);

before return B_OK; in done block.

2) I recompiled that driver and replaced current one. Reboot. 3) Keyboard works. I tried all keys, and they worked fine. But CapsLock worked in some strange way. First, LED won't turn on, but input mode switched (to UPPER keys, I mean). When I pressed CapsLock second time, nothing happened with LED,then I pressed some keys, and there was a delay (~2-3 sec), then letters appears in Terminal. 4) I attached an USB keyboard to laptop. It works perfect, as it was in latest raw build.

At least, now I have *working* laptop's keyboard. Syslog file (syslog.dbg.HP530-5.txt) attached.

Please, notice, that I used external USB mouse.

by sotrud_nik, 10 years ago

Attachment: syslog.dbg.HP530-5.txt added

Tried so steps from http://dev.haiku-os.org/ticket/951, kbd worked

comment:9 by sotrud_nik, 9 years ago

This bug is still not fixed.

I tried fresh revisions, nut no luck.

It looks like there is no big changes in trunk/src/add-ons/kernel/bus_managers/ps2 for about 5 months.

Any steps I can do to provide more info?

Version 0, edited 9 years ago by sotrud_nik (next)

comment:10 by sotrud_nik, 9 years ago

I hope to get this fixed by R1/alpha3

comment:11 by marcusoverhagen, 9 years ago

Owner: changed from marcusoverhagen to nobody
Status: newassigned

I can't reproduce this on my available hardware.

comment:12 by sotrud_nik, 9 years ago

will try latest anyboot image and then I'll report about status

comment:13 by sotrud_nik, 9 years ago

Tried hrev39924 - no luck.

comment:14 by sotrud_nik, 9 years ago

Tried hrev41189 - still no luck

comment:15 by sotrud_nik, 9 years ago

OK, here is a workaround for this bug.

Just disable active multiplexing, then recompile and replace ps2 driver, and after that keyboard and mouse will work well. Tested in hrev41272.

Hint: To do this, you should look at https://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/bus_managers/ps2/ps2_common.cpp , line 150. Insert after 153rd line goto no_support;.

comment:16 by scottmc, 9 years ago

Milestone: R1/alpha3R1/beta1
Priority: normalhigh

bumped up to high, but slid out to beta1 as this shouldn't hold up alpha3.

comment:17 by siarzhuk, 8 years ago

Owner: changed from nobody to siarzhuk
Status: assignedin-progress

comment:18 by siarzhuk, 8 years ago

Fixed in hrev42325.

comment:19 by diver, 8 years ago

Resolution: fixed
Status: in-progressclosed
Note: See TracTickets for help on using tickets.