Opened 9 years ago

Closed 8 years ago

#6688 closed bug (fixed)

Drawing artifacts while using VLC player. Included picture. must see

Reported by: stargatefan Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Not really totally sure how to describe this issue except that the Vesa driver must not be flushing previously rendered frames when using VLC media player.

either way moving a window or program leaves behind image artifacts from that window only above and around the VLC player window. It does not leave them in the active VLC player window.

I am including several pictures.

Not sure where to file this. I will leave it in general

gcc4 Hybrid 38828

Attachments (3)

PA030271.JPG (100.2 KB) - added by stargatefan 9 years ago.
PA030270.JPG (362.7 KB) - added by stargatefan 9 years ago.
PA030269.JPG (255.3 KB) - added by stargatefan 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by stippi

In the ticket title, you say "mediaplayer". In the description, you say "VLC media player". Which one is it? The Haiku one is called "MediaPlayer". If you could attach the promised screenshots, that would be great, too! :-D

comment:2 Changed 9 years ago by stargatefan

Will put them up later tonight. Internet went down last night.

comment:3 Changed 9 years ago by stargatefan

Summary: Drawing artifacts while using mediaplayer. Included picture. must seeDrawing artifacts while using VLC player. Included picture. must see

Changed 9 years ago by stargatefan

Attachment: PA030271.JPG added

Changed 9 years ago by stargatefan

Attachment: PA030270.JPG added

Changed 9 years ago by stargatefan

Attachment: PA030269.JPG added

comment:4 Changed 9 years ago by stargatefan

picture attachment added. Sort of has that windows solitare deck graphic look to it.

comment:5 Changed 9 years ago by stargatefan

I am starting to notice other drawing artifacts in other applications there is a bug about text field boundrys as well that looks to be interlated. To me it seems that the drawing cache output to the video driver VESA in particular in my case is not flushing previous rasterized images in non clipped regions.

Version 0, edited 9 years ago by stargatefan (next)

comment:6 Changed 8 years ago by stargatefan

I haven't seen this for some time. There were a few CID fix related to memory leaks. It's been over a month since I last saw this issue I even tried to reproduce with the exact same movie.

I do belive this got fixed some time ago. I would says its OK to close as fixed as of version 40541 likely earlier.

comment:7 Changed 8 years ago by stippi

Resolution: fixed
Status: newclosed

Hm, I don't remember any fix/commit that could have affected this. Please reopen if you come across it again. Thanks for the update!

Note: See TracTickets for help on using tickets.