Opened 11 years ago

Closed 11 years ago

#8985 closed bug (invalid)

Can't build bootable Haiku 64-bit image on Acer Aspire 5560-7414 laptop

Reported by: Luposian Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Platform: x86-64


I am using Lubuntu 12.04, on an 8Gb PNY Attache' USB stick. I can build "Haiku 64" CD .iso images, but they won't boot (panic at 4th icon). I ran "jam clean" and both tried to rebuild a CD .iso (panic at 4th icon) and just ran "jam clean" and tried creating an Anyboot image, and it ended with the following:

BuildAnybootMBR1 generated/base_mbr.bin /bin/sh: 3: yasm: not found

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:generated/objects/linux/lib ; build/scripts/rm_attrs generated/objects/linux/x86/release/tools/rm_attrs -f generated/base_mbr.bin yasm -f bin src/bin/writembr/mbr.S -O5 -o generated/base_mbr.bin

...failed BuildAnybootMBR1 generated/base_mbr.bin ...

BUILD FAILURE: ...failed updating 1 target(s)... ...skipped 1 target(s)... ...updated 718 target(s)... luposian@luposian-Aspire-5560:~/haiku/haiku$

Xyzzy was able to send me an Anyboot image that, once I burned it to CD in Lubuntu, it booted perfectly on both my Aspire 5560-7414 laptop, as well as my Aspire X1200 desktop.

But nothing I do, on my own, seems to give me a bootable copy.

I use my laptop as my build system, because I'm in my room more often than out in my workshop.

Does Lubuntu HAVE to have Virtual Memory enabled, to build properly? I don't have enough disk space on my USB stick with VM enabled, to build Haiku 64, so I simply reinstalled Lubuntu without and now have 1.3Gb free.

My system has 4Gb of RAM, so I don't think it NEEDS Virtual Memory enabled. But I could be wrong. I do a Verify, when burning the image to CD-R, to make sure everything is good there. It passes that as well.

Hope someone has some answers that yield positive results.

Change History (5)

comment:1 by anevilyak, 11 years ago

The error output already indicates your problem:

/bin/sh: 3: yasm: not found

Meaning your Lubuntu installation is missing yasm, which is a required build tool. You need to install that via whatever package tool Lubuntu has.

comment:2 by umccullough, 11 years ago

comment:3 by Luposian, 11 years ago

Installed yasm, which allowed me to build an Anyboot image. However, upon trying to use k3b to burn it to CD, k3b says "Could not open document". If I open k3b and try to load the Anyboot image into it, the entire program crashes.

Yet, if I double-click on Xyzzy's Anyboot image, k3b has no problem with it.

Oddly enough his image has a MacOS X "System ID" in k3b. Don't know if that has any relevance.

comment:4 by Luposian, 11 years ago

I just noticed something, in the page umccullough pointed to:

"Building Haiku correctly currently requires proper xattr support on the file system you compile it with. Currently, your options are unfortunately rather limited, as for example, ext4 does not sufficiently support this feature. Recommended file systems to use under Linux are XFS, and ReiserFS at this time.

There is a fallback mechanism that is used otherwise, but this is known to be problematic sometimes."

Is it possible, since my Lubuntu install is using ext3 (or ext4, don't recall which), that could be causing my issues?

As well, this is my apt-get line currently:

sudo apt-get install git autoconf automake texinfo flex bison yasm gawk zlib1g-dev build-essential

I'm missing "less", "unzip", "wget", and "zip", according to the suggested string. How critical are those to building Haiku 64? I'll install them anyways... but my free space is now less than 1Gb on my USB stick.

comment:5 by mmadia, 11 years ago

Resolution: invalid
Status: newclosed

Don't use Track for support issues like this. Instead the general mailing list is better.

Version 0, edited 11 years ago by mmadia (next)
Note: See TracTickets for help on using tickets.