Opened 6 years ago

Closed 5 years ago

#10012 closed bug (invalid)

rdesktop doesn't respond to hey quit

Reported by: Kev Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Application Kit Version: R1/Development
Keywords: hey Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I had scripted, using hey, rdesktop to open at fullscreen geometry, then align itself with the edges of the screen so that I could actually see everything. It had been working for months.

I'm not sure when it broke exactly, because I didn't upgrade for a while until just now, but as of hrev46102, hey just hangs if I try to 'hey rdesktop' anything:

/> hey rdesktop get Flags of Window 0

...sits there for minutes. Same thing for any other app (StyledEdit, Terminal, WebPositive, e.g.) works instantly and gives a valid message.

Even 'hey rdesktop quit' doesn't affect it, rdesktop keeps on trucking while Terminal blinks forever until Ctrl+C.

This is true for 1.5.0 gcc2 and 1.7.0post from http://haikuware.ru/software/rdesktop

Change History (8)

comment:1 Changed 6 years ago by diver

Component: - GeneralKits/Application Kit
Owner: changed from nobody to axeld
Version: R1/alpha4.1R1/Development

comment:2 Changed 6 years ago by Kev

Also happens post-PM, confirmed on hrev46164.

comment:3 Changed 6 years ago by Kev

Version: R1/DevelopmentR1/Package Management

comment:4 Changed 6 years ago by Kev

Still happens on hrev46198 gcc2.

comment:5 in reply to:  4 Changed 6 years ago by korli

Replying to Kev:

Still happens on hrev46198 gcc2.

The interesting question would be from which revision it doesn't work anymore. Trying older nightlies and bisecting will help to do that.

comment:6 Changed 6 years ago by Kev

Summary: rdesktop no longer responds to heyrdesktop doesn't respond to hey quit

Sorry, I was mistaken. (I lost my HD contents installing CentOS a few months ago, which included my rdesktop launcher script, so I was going on my faulty memory. I had been playing with 'hey' a bunch around the time I set up rdesktop, so I thought I had used it for that.) I tried it on Alpha 4 and was surprised that it also didn't work there, since I had been using it in full screen a long time since Alpha 4. So it didn't break after all, it was always broken wrt 'hey' functionality. (Although maybe it's a bug that you can't send 'quit'?)

Turns out the way I was doing it was with a '-f' command line option, which is not presented to you if you run rdesktop without any parameters. My bad.

comment:7 Changed 5 years ago by diver

Version: R1/Package ManagementR1/Development

comment:8 Changed 5 years ago by axeld

Resolution: invalid
Status: newclosed

This problem seems to be specific to rdesktop, and not an Haiku bug.

Note: See TracTickets for help on using tickets.