Opened 6 years ago

Closed 5 years ago

#10023 closed bug (duplicate)

Parallel build bugs after PM merge

Reported by: kallisti5 Owned by: bonefish
Priority: low Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: #4091 Blocking:
Has a Patch: no Platform: All

Description

After the PM merge, parallel builds can result in build faults. Re-running the build command seems to resolve the initial failures

Example failure attached.

Attachments (1)

failure.txt (78.3 KB) - added by kallisti5 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by kallisti5

Attachment: failure.txt added

comment:1 Changed 6 years ago by bonefish

This seems to be caused by the same jam bug as #4091. At least the dependency is declared correctly in the Jamfile. If you have more examples, please attach.

comment:2 Changed 5 years ago by kallisti5

Milestone: R1/beta1R1

comment:3 Changed 5 years ago by waddlesplash

Blocked By: 4091 added
Resolution: duplicate
Status: newclosed

Indeed it is a duplicate. The bug described in this issue was fixed, there are still some more in #4091 however.

Note: See TracTickets for help on using tickets.