Opened 6 years ago

Closed 3 years ago

#10027 closed bug (fixed)

ScreenSaver: Fade now screen problem

Reported by: dsjonny Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/ScreenSaver Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

I found a small problem in using the ScreenSaveer preference. If I click on the Fade now monitor, the background color disappears. But if I click on the Screensavers tab and back, or move another window over the ScreenSave window than the back color is there again. Maybe there is some overlay problem? Using hrev46104 nightly anyboot.

Attachments (2)

ScreenSaver.png (19.5 KB ) - added by dsjonny 6 years ago.
0001-Corrected-fade-in-out-monitor-drawing-problem-when-c.patch (878 bytes ) - added by dsjonny 6 years ago.

Download all attachments as: .zip

Change History (8)

by dsjonny, 6 years ago

Attachment: ScreenSaver.png added

comment:1 by dsjonny, 6 years ago

Using r20130926_a5d9833 Package Management the issue is the same, but on the Don't fade monitor...

comment:2 by dsjonny, 6 years ago

Has a Patch: set

comment:3 by dsjonny, 6 years ago

Added patch to correct this problem.

Tested. Works fine.

comment:4 by axeld, 6 years ago

While that may fix the issue, it does look like a work around to an actual problem. I would not recommend applying this patch outside of a release branch without further investigation.

comment:5 by pulkomandy, 4 years ago

Can't reproduce the issue, does it still happen?

comment:6 by pulkomandy, 3 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev50868.

Note: See TracTickets for help on using tickets.