Opened 6 years ago

Closed 6 years ago

#10029 closed bug (fixed)

Default image fails to mount common packagefs

Reported by: mt Owned by: bonefish
Priority: normal Milestone: R1
Component: Kits/Package Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hi, After PM merged I build Haiku from source with "jam -q @vmware-image", then running in VirtualBox. But HaikuDepot can't work with "An error occurred while initializing the package manager: failed to add common packages to common repository" . Any ideas?

Haiku Revision: 735ec4c Build option: --build-cross-tools x86 ../../buildtools/ --build-cross-tools x86_gcc2 -j4 --use-xattr-ref --include-gpl-addons --include-patented-code --use-gcc-pipe Build Host: ubuntu 12.04LTS VirtualBox: 4.2.18

Change History (6)

comment:1 Changed 6 years ago by luroh

I noticed the same problem the other day, please try hrev46137 or later. Possible dupe of #10018.

comment:2 Changed 6 years ago by mt

I build with "@alpha-vmware" profile, and HaikuDepot works without error dialog. I think "@vmware-image" profile lacks something.

comment:3 Changed 6 years ago by luroh

Ah yes, you're right. I was using @nightly-vmware which also works fine now. I can confirm however that HaikuDepot as built using 'jam @vmware-image' (or 'jam haiku-vmware-image') doesn't work properly.

Last edited 6 years ago by luroh (previous) (diff)

comment:4 Changed 6 years ago by anevilyak

Owner: changed from nobody to anevilyak
Status: newin-progress

comment:5 Changed 6 years ago by anevilyak

Component: - GeneralKits/Package Kit
Owner: changed from anevilyak to bonefish
Status: in-progressassigned
Summary: [HaikuDepot] failed to add common packages to common repositoryDefault image fails to mount common packagefs

The issue here seems to be a bit more fundamental: a minimal image has no packages in /boot/common/packages. Furthermore, said folder doesn't actually exist at all in such a case. What then occurs is, when the package kit's attempting to add packages from the common repo during package manager initialization, DaemonClient sends the package_daemon a message requesting information about the 'common' installation location. The latter then fails because the common volume object is NULL. I suspect this is because the packagefs failed to mount at that location entirely due to the missing packages folder, especially since creating the folder, dropping any package into it, and then rebooting is sufficient to rectify the issue.

However, this may be a moot point since /boot/common may be going away entirely.

comment:6 Changed 6 years ago by bonefish

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev46167 by removing /boot/common altogether.

Note: See TracTickets for help on using tickets.