Opened 6 years ago

Closed 3 years ago

#10031 closed bug (fixed)

Terminal nano input broken

Reported by: stippi Owned by: jackburton
Priority: high Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: Cc: siarzhuk
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Navigating back into already written text using the cursor keys, and then typing something to insert, results in all sorts of weird behavior. Text disappearing, random letters appearing. The internal text is also screwed up, these are not just rendering bugs. This started happening after the PM merge, but it may also be due to newer versions of some packages.

Change History (15)

comment:1 by bonefish, 6 years ago

Cc: siarzhuk added

FWIW, I saw such a problem quite a while back in one of the first iterations (or even the first) of building packages. In a later iteration the problem seemed to be gone, so I figured it was a temporary issue due to our messing with different package versions and configurations. Admittedly I pretty much exclusively used Pe afterwards.

My assumption is that it may have to do with nano using an external ncurses package (different version?) now, while formerly the Haiku build system produced the library. Maybe Siarzhuk has an idea.

comment:2 by siarzhuk, 6 years ago

I suspect the nano misbehaviour too. Is it local or remote instance? There are some info how to get the program output capture log received by Terminal - see starting from ticket:3164#comment:11 Parsing this capture log can help to understand what the nano tries to write in the Terminal. I'm on the vactions until 8 Oktorber, so I have no PM-Haiku here to try to reproduce this problem.

in reply to:  1 comment:3 by Kev, 6 years ago

Replying to bonefish:

FWIW, I saw such a problem quite a while back in one of the first iterations (or even the first) of building packages.

If this is the same issue as ticket:3164#comment:11 in the end, I can confirm it also happens on alpha 4 (Revision hrevr1alpha4-44702). (Not sure when building packages was introduced but since I have a separate alpha4 partition on hand I thought I'd test it there in case that was helpful.)

comment:4 by stippi, 6 years ago

Meanwhile I have switched from a GCC4 based hybrid to the default GCC2 based one, since the other way around I saw various other issues. The problem persists however and is especially annoying. I don't really have the time to dig into it myself, and it should be reproducible on any current Haiku version.

Last edited 6 years ago by diver (previous) (diff)

comment:5 by augiedoggie, 6 years ago

I believe this is because our current version of nano doesn't properly handle the 'cbt' capability of terminals. Setting TERM to xterm-color should work around the problem as it doesn't advertise this feature(xterm and xterm-256color do)

You can also type ctrl-l to redraw the screen if you are in the editor and it is messed up.

comment:6 by Kev, 6 years ago

Thanks! The Ctrl+L trick works, but doing "set TERM=xterm-color" in the shell before connecting via ssh didn't help...did you mean something different?

comment:7 by augiedoggie, 6 years ago

I meant 'export TERM=xterm-color'. This seemed to help with some of the problems I saw locally but I didn't try it over ssh.

in reply to:  6 comment:8 by anevilyak, 6 years ago

Replying to Kev:

Thanks! The Ctrl+L trick works, but doing "set TERM=xterm-color" in the shell before connecting via ssh didn't help...did you mean something different?

It should be noted that, if you're doing this over ssh, you should be running the set/export *after* logging in remotely, since otherwise the shell on the remote end could quite possibly reset TERM as a consequence of parsing its user profile / configuration scripts while connecting.

comment:9 by Kev, 6 years ago

I tried 'export TERM=xterm-color' then 'nano' after logging in via ssh, and the behaviour persists.

Last edited 6 years ago by Kev (previous) (diff)

comment:10 by waddlesplash, 5 years ago

Is there a reason we aren't just setting Terminal to "xterm-color" by default?

in reply to:  10 comment:11 by siarzhuk, 5 years ago

Replying to waddlesplash:

Is there a reason we aren't just setting Terminal to "xterm-color" by default?

Yes, there are. Haiku Terminal emulates "xterm" and "xterm-256color" term-types but not "xterm-color". Despite the name "xterm-color" is far away from "true" xterms, AFAIR.

comment:12 by pulkomandy, 5 years ago

Priority: normalhigh

comment:13 by pulkomandy, 5 years ago

Similar issues can be seen in arm-none-eabi-gdb (available in the repos) and LFT's "Hardware Chiptune" tracker (also ncurses based).

comment:14 by pulkomandy, 5 years ago

I tried to build an updated ncurses. There wasn't a stable release but they publish patches with quite a lot of fixes (the patch is currently almost as big as the original release archive). However the current version seems to get stuck in an endless loop during build so I couldn't test it.

comment:15 by korli, 3 years ago

Resolution: fixed
Status: newclosed

nano should be usable in hrev50662.

Note: See TracTickets for help on using tickets.