Opened 6 years ago

Last modified 8 months ago

#10052 new bug

Some issues with OpenGL apps

Reported by: Giova84 Owned by: kallisti5
Priority: normal Milestone: R1
Component: Kits/OpenGL Kit Version: R1/Development
Keywords: Some issues with OpenGL apps libglu Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

hrev46154 Since this revision, i have found some issues with OpenGL games "BillardGL" and "Chromium". With BillardGL i have noticed that runs much slower than before: is noticeable. BillardGL relies on "LibGLU.so", which is linked to "/system/lib/libGLU.so.1.3.1" I have overridden this library, by creating a "lib" folder in BillardGL path, using a libGL.so from a old nightly build, linked as libGLU.so, and with this "Hack" BillardGL runs better.

The second issue is related to Chromium: when i attempt to run Chromium, for a second i can see a blank windows which tells "no render found" and if i run Chromium from a Terminal window i can read:

resolve symbol "__ti11BGLRenderer" returned: -2147478780
no renderer found! 
BRect(l:0.0, t:0.0, r:1279.0, b:1023.0)
Segmentation violation

And inside the syslog:

KERN: runtime_loader: /boot/system/add-ons/opengl/Legacy Software Rasterizer: Could not resolve symbol '__ti11BGLRenderer'
KERN: runtime_loader: /boot/system/add-ons/opengl/Legacy Software Rasterizer: Troubles relocating: Symbol not found
KERN: vm_soft_fault: va 0x0 not covered by area in address space
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x5e5022, write 0, user 1, thread 0x8dde
KERN: vm_page_fault: thread "Chromium" (36318) in team "Chromium" (36318) tried to read address 0x0, ip 0x5e5022 ("libroot.so_seg0ro" +0x80022)

These games run fine on hrev46102 gcc2h

Change History (7)

comment:1 Changed 6 years ago by kallisti5

I'm currently working on redoing *everything*. A lot of GL stuff broke with the PM changes. Sit tight. (i'm actually compiling Mesa as I type this)

comment:2 Changed 6 years ago by Giova84

As i can see on older nigthlies, Chromium use system/add-ons/opengl/gcc4/Software Rasterizer instead of Legacy Software Rasterizer. hrev46154 is marked as gcc2h.. Why miss some components?

EDIT: We reply at the same time!

Last edited 6 years ago by Giova84 (previous) (diff)

comment:3 Changed 6 years ago by Giova84

In addition i have also noticed that mesa-7.8.2-3-x86_gcc2.hpkg and mesa_x86-9.1.1-1-x86_gcc2.hpkg packages, just contain the ".PackageInfo" file and nothing else.

Kallisti5: when will be available the newer Mesa? :-)

comment:4 Changed 6 years ago by kallisti5

the mesa package was a dummy package after the PM migration. I'm currently working on moving our entire OpenGL kit into Mesa. For more information see the mesa-dev mailing list and search for Haiku.

http://lists.freedesktop.org/archives/mesa-dev/2013-October/thread.html

comment:5 Changed 4 years ago by pulkomandy

New mesa packages are available now. Does it help?

comment:6 Changed 4 years ago by Giova84

Hi,

Unfortunately these apps ("BillardGL" and "Chromium") no longer work on Haiku, so I can't answer to your question.

Would be nice to port them again on Haiku, however (also to see if the new mesa packages help in terms of performances)

comment:7 Changed 8 months ago by cocobean

This bug is now resolved.

BillardGL 1.75 - https://sourceforge.net/projects/billardgl/
Tested BillardGL 1.75-1 on hrev52300 x86. Works fine. No major performance issues. 

Chromium B.S.U. 0.9.16.1 - https://sourceforge.net/projects/chromium-bsu/
Issues resolved in hrev52300 x86 w/ Mesa 7.9.2-11.

Note: See TracTickets for help on using tickets.