Opened 9 years ago

Closed 8 years ago

#10056 closed bug (fixed)

Worms Armageddon leaked beta: ingame audio mangled and causes crashes

Reported by: Muzer Owned by: jackburton
Priority: normal Milestone: R1
Component: Kits/Game Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86

Description

When you get Worms Armageddon to run after hacking around the stack allocation issue, the frontend works fine. However, ingame, audio is replaced mostly by white-ish noise, and the game frequently crashes (including always crashing when the game ends). It is always a segfault in GameSoundBuffer::Play(void*, int64) - an example stacktrace is attached.

A workaround is to stop the media server whilst playing the game, which my normal script does. Obviously this results in no sound at all.

Instructions to reproduce:

  • Download the leaked WA beta (from http://pulkomandy.tk/~beosarchive/unsorted/ftp.beos.hu/ftp.beos.hu/beos/applications/games/worms/ for example)
  • Extract it to some directory
  • Download my package of fixes so far from http://tim32.org/~muzer/WA-fix-debug.tar.bz2 (the debug version linked here doesn't disable the media server, so that these crashes can be experienced) and extract this into the directory containing the WA binary.
  • cd into the WA-fix directory extracted above, and run ./fix.sh . This will apply a binary patch to the executable and move various things around so the game will actually run (apologies for the hackiness of the current fixes, I couldn't get LD_PRELOAD to work for some reason).
  • cd .. and ./PlayWorms.sh
  • Reproduce the crash by starting a game (keep pressing the top-left icon for a quick game) and subsequently ending the game (for example by pressing escape and selecting quit).

I'm afraid I'm not a BeOS/Haiku user, but instead an interested Worms Armageddon player - I have never used either OS before a few days ago, so bear with me if I've done anything wrong (in particular, I'm not actually sure which kit this belongs in).

Attachments (4)

WA-1804-debug-02-10-2013-12-25-35.report (27.8 KB ) - added by Muzer 9 years ago.
Stack trace from audio crash
WA-1798-debug-03-10-2013-22-55-54.report (13.6 KB ) - added by Muzer 9 years ago.
A stack trace with debug library
WA1.png (103.5 KB ) - added by kallisti5 8 years ago.
WA2.png (53.1 KB ) - added by kallisti5 8 years ago.

Download all attachments as: .zip

Change History (8)

by Muzer, 9 years ago

Stack trace from audio crash

comment:1 by Muzer, 9 years ago

"cd into the WA-fix directory extracted above" <-- should now say WA-fix-debug

by Muzer, 9 years ago

A stack trace with debug library

by kallisti5, 8 years ago

Attachment: WA1.png added

by kallisti5, 8 years ago

Attachment: WA2.png added

comment:2 by kallisti5, 8 years ago

Looks like it's working after your patches now?

comment:3 by pulkomandy, 8 years ago

The sound is still crashing if you don't kill media_server before starting. This second bug should be investigated and fixed if possible.

comment:4 by pulkomandy, 8 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev48487.

Note: See TracTickets for help on using tickets.