Opened 6 years ago

Closed 6 years ago

#10072 closed bug (fixed)

Deskbar menu closes when mouse cursor is over separator

Reported by: idefix Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc: degea@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tested with hrev46187.

Steps to reproduce:

  • Click on the Deskbar leaf and keep the mouse button down
  • Move the mouse pointer over a separator in the Deskbar menu.
  • The menu closes

The menu should stay open.

If the mouse button is up when the mouse pointer moves over a separator, the menu stays open.

The menu's in Webpositive also exhibit this behaviour.

The right-click menu on the desktop doesn't exhibit this behaviour.

Change History (4)

comment:1 by ttcoder, 6 years ago

Cc: degea@… added

irritating recent little regression in the BMenu tracking code indeed... post 46xxx as I recall. I gotta use the "click to open" behavior in order to use the deskbar (and other menus) now.. I'd much rather keep the mouse button held down all along, faster that way..

comment:2 by anevilyak, 6 years ago

The only likely candidate in relatively recent time would be hrev45988. Please verify if possible.

comment:3 by jscipione, 6 years ago

Menu code is tricky, hrev45977 is more likely the cause. My guess for a fix is to include separator items in BMenu::_HitTestItems() again and then skip the separators on a case-by-case basis so as to prevent the crash described in #4417 while being careful not to regress the bug described by #6610.

comment:4 by jscipione, 6 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev46191 by reverting hrev45988

Thanks for reporting.

Note: See TracTickets for help on using tickets.