Opened 6 years ago

Closed 6 years ago

Last modified 2 months ago

#10088 closed bug (fixed)

pcnet broken under vbox

Reported by: jessicah Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Network/pcnet Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #10103, #13376
Has a Patch: no Platform: All

Description

In hrev46220 pcnet no longer works under VirtualBox.

I now get two pcnet interfaces showing up; the first doesn't seem to try getting an IP at all, and the second one can only setup a link-local IP rather than acquire a DHCP lease.

Attachments (6)

listdev.txt (1.1 KB) - added by jessicah 6 years ago.
listimage-driver.txt (1.3 KB) - added by jessicah 6 years ago.
syslog.txt (58.9 KB) - added by jessicah 6 years ago.
ifconfig-1.txt (869 bytes) - added by jessicah 6 years ago.
before getting link local IP
ifconfig-2.txt (913 bytes) - added by jessicah 6 years ago.
after getting link local IP (takes several minutes)
syslog hrev46236.txt (68.1 KB) - added by jessicah 6 years ago.

Download all attachments as: .zip

Change History (19)

Changed 6 years ago by jessicah

Attachment: listdev.txt added

Changed 6 years ago by jessicah

Attachment: listimage-driver.txt added

Changed 6 years ago by jessicah

Attachment: syslog.txt added

Changed 6 years ago by jessicah

Attachment: ifconfig-1.txt added

before getting link local IP

Changed 6 years ago by jessicah

Attachment: ifconfig-2.txt added

after getting link local IP (takes several minutes)

comment:1 Changed 6 years ago by anevilyak

Owner: set to korli
Status: newassigned

comment:2 Changed 6 years ago by korli

The glue code seems correct, but the compatibility layer doesn't yet support the case when both drivers support the device. The one which probes with the higher priority should win at this place.

comment:3 Changed 6 years ago by anevilyak

Blocking: 10103 added

(In #10103) Sounds like a duplicate of #10088. More information would be needed in order to determine that though, please attach a syslog.

comment:4 Changed 6 years ago by korli

Please try hrev46236 or newer. Thanks!

comment:5 Changed 6 years ago by jessicah

Now getting just the one device; but it's still unable to get an IP address via DHCP.

Changed 6 years ago by jessicah

Attachment: syslog hrev46236.txt added

comment:6 Changed 6 years ago by korli

Please try hrev46241 or newer. Thanks!

comment:7 Changed 6 years ago by jessicah

Still no joy. In ifconfig, it says it sends packets, but none received:

Receive: 0 packets, 0 errors, 0 bytes, 0 mcasts, 0 dropped
Transmit: 6 packets, 0 errors, 1842 bytes, 0 mcasts, 0 dropped

comment:8 Changed 6 years ago by korli

I tested a bit and no interrupt is ever received when using PCnet FAST III on VirtualBox 4.3.0. To complete that, I tried booting FreeBSD 9.2 and it wasn't successful either with this network device whereas all was good mit PCnet-PCI II or Intel PRO 1000/MT.

To conclude, PCnet FAST III in VirtualBox doesn't work well at least with the pcn driver. Maybe it would be worth testing with another OS (ie Linux). I understand the le driver worked well with the PCnet FAST III device (in 16-bit mode). We could try to blacklist the device in the case of Virtualbox as a workaround, the fallback driver would then work good enough. Opinions?

comment:9 Changed 6 years ago by korli

Finally found a trick to get this card working on FreeBSD:

ifconfig pcn0 media 10baseT/UTP
ifconfig  pcn0 up
dhclient pcn0

Now I tried on Haiku "ifconfig /dev/net/pcnet/0 media 10baseT" and only got a "General system error" back.

comment:10 Changed 6 years ago by korli

Also see https://www.virtualbox.org/ticket/861

Obsolete. For FreeBSD use the E1000 emulation. 

comment:11 Changed 6 years ago by jessicah

Okay, thanks korli. E1000 it is then! We'll need some docs somewhere to point out that PCNET-III in VirtualBox shouldn't be used, unless you go the way of blacklisting it.

comment:12 Changed 6 years ago by korli

Resolution: fixed
Status: assignedclosed

Fixed in hrev46253. Still not being able to set the media with ifconfig is a bug.

comment:13 Changed 2 months ago by waddlesplash

Blocking: 13376 added
Note: See TracTickets for help on using tickets.