Opened 7 years ago

Closed 6 weeks ago

Last modified 6 weeks ago

#10117 closed enhancement (fixed)

"package" command creates .hpkg roughly 2x size bigger than haikuporter

Reported by: mmadia Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Applications/Command Line Tools Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

hrev46261

The command line tool, package creates packages that are roughly twice as large as those created by haikuporter. For example, manually extract system/packages/perl-5.10.1-6-x86_gcc2.hpkg (9.61MiB) into its own directory and run package create perl-test.hpkg The resulting files size is 18.92MiB. Using package create -9 ... results in 18.92MiB as well.

Change History (7)

comment:1 by mmadia, 7 years ago

The issue is that package create <package-name> (without the -C <dir>) will end up including the newly created <package-name> in the final <package-name>.

Using package create -C <dir> <package-name> results in .hpkgs of similar size to haikuporter.

comment:2 by diver, 7 years ago

Owner: changed from nobody to bonefish
Status: newassigned

comment:3 by bonefish, 7 years ago

Owner: changed from bonefish to nobody
Type: bugenhancement

I would consider trying to create the package inside the tree to be packaged a user error, but it certainly wouldn't harm to skip the package file explicitly.

comment:4 by pulkomandy, 2 months ago

Should we make the -C option mandatory when creating a package? Current command line syntax seems a bit confusing.

comment:6 by waddlesplash, 6 weeks ago

Resolution: fixed
Status: assignedclosed

Fix merged in hrev54248.

comment:7 by nielx, 6 weeks ago

Milestone: R1R1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.