Opened 7 years ago

Closed 7 years ago

#10146 closed bug (invalid)

Expander no longer displays contents of .hpkg archives

Reported by: ttcoder Owned by: korli
Priority: normal Milestone: R1
Component: Applications/Expander Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

Double-clicking an .hpkg is a snappy alternative to displaying its contents in Terminal with the package command.

But in hrev46284 it no longer works; odd regression, this used to work a few days ago and there were little to no changes related to Expander in the meantime?.

NOTE -- If you run e.g. Expander /system/packages/autoconf-2.69-5-x86_gcc2.hpkg (and click "show contents") it does show the package's contents. However, open /system/packages/autoconf-2.69-5-x86_gcc2.hpkg does not work, the Expander window comes up with an empty listing... and no error message.

Change History (3)

comment:1 by humdinger, 7 years ago

Both approaches work here with hrev46288.

comment:2 by ttcoder, 7 years ago

Dang it.. running "ps" in Terminal I realized in the 'bad' case it does not work because it's running an old 46xxx version of Expander (some background: I don't initialize the partition when upgrading to a newer hrev, I just move around the old haiku files to trash or to another folder, and thus I end up with several copies of applications ..etc, and when an app is invoked by MIME signature it's unpredictable which instance of the app will be selected.. But fortunately this is the last time I get bitten by this, since in PM Haiku the apps live in .hpkg files and thus old instances are "inert", only the active ones are "live").

Please close as invalid.

comment:3 by humdinger, 7 years ago

Resolution: invalid
Status: newclosed

Praise PM! :) Closing ticket...

Note: See TracTickets for help on using tickets.