Opened 6 years ago

Closed 6 years ago

#10155 closed bug (duplicate)

Can't boot nightly from USB anymore

Reported by: x-ist Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: #10043 Blocking:
Has a Patch: no Platform: All

Description

This is haiku-nightly-hrev46296-x86gcc2hybrid-anyboot. Tried to boot from USB and got this KDL. The last time I tried a nightly was at hrev46255, which booted nicely on my Acer Aspire 7551G and is still installed on the harddisk.

Attachments (10)

20131028_211240_resized.jpg (172.9 KB ) - added by x-ist 6 years ago.
syslog_hrev46263_corsair_ok (193.3 KB ) - added by x-ist 6 years ago.
syslog_hrev46263_transcend_sdcard_KDL.TXT (74.3 KB ) - added by x-ist 6 years ago.
syslog_hrev46284_corsair_ok (228.5 KB ) - added by x-ist 6 years ago.
syslog_hrev46284_transcend_sdcard_KDL.TXT (73.3 KB ) - added by x-ist 6 years ago.
syslog_hrev46284_corsair_ok.2 (228.6 KB ) - added by x-ist 6 years ago.
syslog_hrev46284_transcend_sdcard_KDL.2.TXT (73.8 KB ) - added by x-ist 6 years ago.
syslog_hrev46296_corsair_ok (228.6 KB ) - added by x-ist 6 years ago.
syslog_hrev46296_transcend_sdcard_KDL.TXT (73.8 KB ) - added by x-ist 6 years ago.
syslog_hrev46255_transcend_sdcard_ok (229.2 KB ) - added by x-ist 6 years ago.

Download all attachments as: .zip

Change History (17)

by x-ist, 6 years ago

Attachment: 20131028_211240_resized.jpg added

comment:1 by bonefish, 6 years ago

Can you build your own images? Can you provide syslogs?

comment:2 by jua, 6 years ago

Might be related to #10043, which was reverted in hrev46261. Could you try using a different USB stick? Only some sticks have the problem from the other ticket and if it works with a different stick, it might be that.

in reply to:  2 comment:3 by bonefish, 6 years ago

Replying to jua:

Might be related to #10043, which was reverted in hrev46261.

Oh, I figured the cause would be hrev46287, though that would likely mean that the BIOS read incorrect data from the stick. Could you try a version between the two (i.e. >= hrev46261, but < hrev46287) to verify? A syslog from a failing version would be helpful as well.

comment:4 by x-ist, 6 years ago

It seems it depends on the type of storage. Unfortunately I don't remember which stick I used for hrev46255. So now I have a Transcend 32GB SD card (the problematic one) and a Corsair 8GB USB stick (which works). I have syslogs for both storages from hrev46263, hrev46284 and hrev46296.

by x-ist, 6 years ago

Attachment: syslog_hrev46263_corsair_ok added

by x-ist, 6 years ago

Attachment: syslog_hrev46284_corsair_ok added

by x-ist, 6 years ago

by x-ist, 6 years ago

Attachment: syslog_hrev46296_corsair_ok added

comment:5 by x-ist, 6 years ago

Sorry, the second pair of syslogs from hrev46284 is actually from hrev46296. I attached them renamed again.

comment:6 by x-ist, 6 years ago

And finally the syslog from hrev46255 which booted perfectly from the Transcend SD card.

comment:7 by bonefish, 6 years ago

Blocked By: 10043 added
Resolution: duplicate
Status: newclosed

So, to sum it up, the Corsair stick works and always did, and booting off the Transcend stick broke between hrev46255 and hrev46263. This supports jua's theory. Closing as duplicate of #10043.

Note: See TracTickets for help on using tickets.