Opened 6 years ago

Closed 3 years ago

#10157 closed enhancement (duplicate)

[app_server] reasonable resolution display support

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc: stippi
Blocked By: #13087 Blocking:
Has a Patch: no Platform: All

Description

I've got my hands on a recent MacBook Pro with retina reasonable resolution display and discovered that Haiku doesn't support it which makes fonts and icons look blurry. Since it's the only laptop I have here, working with Haiku is going to be pretty painful, so I'd appreciate is someone could look into this issue. Here's a few links which might be useful:

http://blog.qt.digia.com/blog/2013/04/25/retina-display-support-for-mac-os-ios-and-x11 http://www.freelists.org/post/haiku-development/Plans-for-HiDPI-display-support

Attachments (1)

blurry-fonts-and-icons.png (235.8 KB ) - added by diver 6 years ago.

Download all attachments as: .zip

Change History (4)

by diver, 6 years ago

Attachment: blurry-fonts-and-icons.png added

comment:1 by stippi, 6 years ago

What do you mean "Haiku does not support it"? Do you mean your virtual machine software does not support it? Or do you mean the resolution should be available in the virtual machine, but Haiku does not support it?

comment:2 by axeld, 6 years ago

What is that screenshot actually showing? Haiku in a emulator, or Haiku on the real machine? If the graphics card is not supported, Haiku will always only be able to use the resolutions the VESA BIOS of that card offers.

Either way, since Haiku does not support high resolution displays, you will see tiny icons and fonts, not blurry ones. If you see blurry things, it's something that is outside of the realm of Haiku.

comment:3 by diver, 3 years ago

Blocked By: 13087 added
Resolution: duplicate
Status: newclosed

It appears that blurry fonts were due to the lack of HiDPI support in VirtualBox. It doesn't expose native resolution. Today I managed to boot Haiku natively on my MacBook Pro (with a lot of help help from jessicah) and after changing font size to 20(!) it's quite usable. Not all GUI parts scale though. I'll close it s a dupe of #13087.

Note: See TracTickets for help on using tickets.