Opened 10 years ago

Last modified 3 months ago

#10162 assigned bug

WIFI doesn't automatically connect

Reported by: Giova84 Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/net_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #17064
Platform: All

Description (last modified by diver)

I have an atheros wifi card, WPA2 auth method. Every time that I boot Haiku, also if i choose to store the details, i have to manually select my SSID.

syslog attached.


Attachments (1)

syslog (17.9 KB ) - added by Giova84 10 years ago.

Download all attachments as: .zip

Change History (18)

by Giova84, 10 years ago

Attachment: syslog added

comment:1 by diver, 10 years ago

Component: ServersServers/keystore_server
Description: modified (diff)
Owner: changed from nobody to mmlr
Platform: x86All

comment:2 by diver, 10 years ago

Do you need to enter your password after connecting to your SSID?

comment:3 by Giova84, 10 years ago

No, i don't need to enter again my password. So the keystore_server shouldn't be the culprit.

comment:4 by Giova84, 10 years ago

I have momentarily solved with the following workaround: Inside UserBootScript i have added

ifconfig /dev/net/atheroswifi/0 join MYSSID

But is only a temporary workaround :-)

comment:5 by diver, 10 years ago

Component: Servers/keystore_serverServers/net_server
Owner: changed from mmlr to axeld

comment:6 by miqlas, 8 years ago

I have the same problem with my Atheros WLAN adapter, the network also WPA2.

Haiku (recent nightly gcc2h) does not ask for password, it just does not connect automatically, so i need to go to the right click menu of NetworkStatus replicant, and select my SSID, then it connectin without problem.

I will try the UserBootScript workaround, but it would be better to locate and eliminate this bug for the new users.

Last edited 8 years ago by miqlas (previous) (diff)

comment:7 by humdinger, 8 years ago

I does work for my iprowifi4695 after setting the WLAN in the Network preferences. Have you tried that?

comment:8 by axeld, 6 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:9 by X512, 3 years ago

Still present in hrev53639.

WiFi adapter is [168c:002b] Atheros AR9285.

comment:10 by JeremyF, 2 years ago

device Network controller [2|80|0]

vendor 168c: Qualcomm Atheros device 0036: QCA9565 / AR9565 Wireless Network Adapter

Problem still exists (hrev55022)

comment:11 by nephele, 23 months ago

On a hunch... does the SSID that is problematic contain a space? I have noticied that common SSID names with spaces like "FritzBox NNNN" seem to not work for reconnecting, but I have other single name SSID's that do work.

Yesterday I renamed a SSID from the FritzBox NNNN style to a single word name and afterwards the new SSID managed to autoconnect, thus my hunch that this might be related to spaces. (could also explain

comment:12 by JeremyF, 23 months ago

The SSID has no space. It's a one block "UPCxxxxxxx" (x= numbers)

comment:13 by nephele, 23 months ago

Blocking: 17064 added

comment:14 by 6foot3, 9 months ago

Still present in hrev56391. With Haiku starting to look like it's ready for prime time, this should probably be addressed.

comment:15 by waddlesplash, 9 months ago

Yeah, probably. It's only two clicks to do it manually if you have the password saved, but that's two clicks less than every other OS :)

Likely the entire autoconnect logic needs to be totally scrapped and rewritten. It's never worked for me, anyway.

comment:16 by nephele, 9 months ago

It works fine for me most of the time, maybe somebody should check how it works first before scrapping it :P

comment:17 by vidrep, 3 months ago

The problem is still here with hrev56836.

Note: See TracTickets for help on using tickets.