Opened 6 years ago

Closed 5 years ago

#10199 closed bug (fixed)

Haiku x86-64 no longer jams (builds) Haiku x86-64...

Reported by: Luposian Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

Tried downloading the latest revision of Haiku x86-64 and JAMing, but it crashed right after starting. I figured, "Ok, lets delete everything and start over". Upon doing so, the same problem. JAM doesn't work. Or crashes. Or something.

I ran into a similar non-build situation in Haiku x86-64, but it was finally resolved with a newer version of Haiku x86-64, pulled from Haiku Files.

Should I try that first or does someone have some idea how to diagnose this particular issue?

"Save Report" does nothing, so far as I can tell (where is the "report" saved to?). "Terminate" simply puts me back to the Terminal prompt with a blinking cursor.

I have not yet tried "Debug". Should I post an image of that?

Attachments (3)

screenshot1.png (112.8 KB ) - added by Luposian 6 years ago.
Haiku x86-64 JAM crash
jam-359-debug-11-11-2013-15-37-01.report.zip (468.6 KB ) - added by Luposian 6 years ago.
jam-585-debug-11-11-2013-15-41-30.report.zip (469.2 KB ) - added by Luposian 6 years ago.

Download all attachments as: .zip

Change History (8)

by Luposian, 6 years ago

Attachment: screenshot1.png added

Haiku x86-64 JAM crash

comment:1 by Luposian, 6 years ago

Oops... didn't notice the reports (1st and 2nd) were right on my desktop. Just uploaded them as ZIP, because the raw text was over 8Mbytes each file. Too large to upload (w/ 5Mbyte limit).

comment:2 by diver, 6 years ago

Component: - GeneralApplications/Command Line Tools
thread 360: team 359 debug task 
	thread 359: jam (main)
		state: Exception (Segment violation)

		Frame		IP			Function Name
		-----------------------------------------------
		0x7fc84c2b7380	0x3c5e3d8d6f	jcache + 0xb
			Disassembly:
				jcache:
				0x0000003c5e3d8d64:               55  push %rbp
				0x0000003c5e3d8d65:           4889e5  mov %rsp, %rbp
				0x0000003c5e3d8d68:   4881ec60040000  subq $0x460, %rsp
				0x0000003c5e3d8d6f:   4889bda8fbffff  mov %rdi, 0xfffffba8(%rbp) <--

			Frame memory:
				Unavailable (Bad address)
		0x7fc84c2b73a0	0x3c5e3dddbb	yyline + 0x119
		0x7fc84c2b9be0	0x3c5e3ddf6e	yylex + 0x58
		0x7fc84c2bbd90	0x3c5e3dfd00	yyparse + 0x29c
		0x7fc84c2bbe10	0x3c5e3dbbc6	parse_file + 0x3e
		0x7fc84c2bbe50	0x3c5e3e387b	compile_include + 0xfb
		0x7fc84c2bbea0	0x3c5e3e3b61	compile_on + 0xd6
		0x7fc84c2bbee0	0x3c5e3e3fb6	compile_rules + 0x4b
		0x7fc84c2bbf40	0x3c5e3e3a4f	compile_local + 0x151
		0x7fc84c2bbf80	0x3c5e3e4015	compile_rules + 0xaa
		0x7fc84c2bbfe0	0x3c5e3e3a4f	compile_local + 0x151
		0x7fc84c2bc020	0x3c5e3e4015	compile_rules + 0xaa
		0x7fc84c2bc0a0	0x3c5e3e3f05	evaluate_rule + 0x233
		0x7fc84c2bc150	0x3c5e3e3c82	compile_rule + 0xf0

comment:3 by Luposian, 6 years ago

While waiting for a response, I decided to try installing a newer nightly revision of Haiku x86-64 onto the second partition. Upon doing so and rebooting, I was greeted with "Haiku bootsector not found" or something.

This initially cause me some sense of panic, but then I remembered that something to do with the bootsector (Boot manager?) was changed somewhat recently and there was mention that the older boot manager would not recognize it or be able to use it.

So, this likely being the case, how do I get the older boot manager to recognize the newer bootsector? Or must I simply install the newest Haiku nightly onto the main partition via CD or other route?

I'm hoping the newer revision solves my issue... at least it's something to try while waiting for another solution...

comment:4 by Luposian, 5 years ago

Please close this ticket. This issue is no longer a problem.

comment:5 by diver, 5 years ago

Resolution: fixed
Status: newclosed

Thanks for the update.

Note: See TracTickets for help on using tickets.