Opened 6 years ago

Closed 5 years ago

#10212 closed bug (fixed)

HDA: Audio plays with background pops and clicks

Reported by: MichaelPeppers Owned by: jua
Priority: normal Milestone: R1
Component: Drivers/Audio/HDA Version: R1/Development
Keywords: hda sound pops Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In both MediaPlayer and MidiPlayer the audio of any file I tested (MIDI, mp3, mp4, flac, mkv) has clicks and pops in the background

listdev:

device Multimedia controller (Audio device) [4|3|0]
  vendor 10de: NVIDIA Corporation
  device 03f0: MCP61 High Definition Audio

A syslog with info about the HDA hardware initialization can be found here if it's needed: https://dev.haiku-os.org/attachment/ticket/10193/syslog-trimmed

Attachments (1)

syslog (5.0 KB) - added by MichaelPeppers 5 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by MichaelPeppers

It's hrev46335 by the way

comment:2 Changed 6 years ago by MichaelPeppers

Booted into Haiku again today but I can't reproduce it as of now, same revision, same files tested.

Changed 5 years ago by MichaelPeppers

Attachment: syslog added

comment:3 Changed 5 years ago by MichaelPeppers

hrev47801, audio stopped working altogether

comment:4 Changed 5 years ago by anevilyak

Owner: changed from korli to jua
Status: newassigned

comment:5 Changed 5 years ago by jua

Sorry for the regression. nVidia HDA audio works again with hrev47804, please check again with that.

comment:6 Changed 5 years ago by MichaelPeppers

Tested and confirmed, audio works perfectly now (except for #10193), this bug can be closed.

comment:7 Changed 5 years ago by anevilyak

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.