Opened 5 years ago

Closed 5 years ago

#10268 closed bug (no change required)

Input nothing,but haiku think I did - haiku-nightly-hrev46455-x86gcc2hybrid-vmware

Reported by: dillcn Owned by: axeld
Priority: normal Milestone: R1/beta1
Component: Applications/Tracker Version: R1/Development
Keywords: input error Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When I enabled "Enable type-ahead filtering" in Tracker preferences, and opened boot and boot/home windows, all folders inside disappeared (As NO.1 arrow pointed). But after I typed BackSpace key or Esc key, all of them appeared.

I think the reason is the OS detected some characters that the user did not input. May be it's the same reason that when I clicked the left key of the mouse in /boot address bar, some rectangles appeared.

BTW, may be there is another displaying bug as NO.2 arrow pointed out in the attached picture.

Haiku revision: haiku-nightly-hrev46455-x86gcc2hybrid-vmware

Attachments (2)

haiku-nightly-hrev46455-x86gcc2hybrid-vmware.png (79.6 KB) - added by dillcn 5 years ago.
Enable type-ahead filtering ERROR.png (57.0 KB) - added by dillcn 5 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 years ago by anevilyak

Component: - GeneralApplications/Tracker
Owner: changed from nobody to axeld
Priority: highnormal

comment:2 Changed 5 years ago by dillcn

When I reboot the VMware and enter Haiku, the reported error above did not happen again with "Enable type-ahead filtering" enabled. I don't know why.

But I find another problem: When I typed in filter charactors, displayed folders are more than expected (see attached picture Enable type-ahead filtering ERROR.png).I think it may be a bug.

Last edited 5 years ago by dillcn (previous) (diff)

Changed 5 years ago by dillcn

comment:3 Changed 5 years ago by rexmorgan

I can't seem to reproduce this on nightly build hrev46638-x86gcc2hybrid. With my limited search skills, I couldn't find a changeset that may have fixed this.

What keymap are you using? I'm curious if that could have something to do with it.

comment:4 Changed 5 years ago by dillcn

I used the default keymap 'US-International'. I reproduced this following these steps: 1) open home directory; 2) menu: window-preferences-Tracker preferences-windows:select Enable type-ahead filtering; 3) add new folder 'debian','des','made'; 4) type 'de',the results are: 'debian','des','Desktop','made',the last 'made' is not expected.

BTW,some times the error I mentioned in this bug report that I typed nothing but all the folders were disappeared while the lower left corner of window show a ‘block’as shown in attachment 'haiku-nightly-hrev46455-x86gcc2hybrid-vmware.png'. This problem is hard to reproduce,but it certenly exist.

comment:5 Changed 5 years ago by humdinger

In your example, showing the "made" folder is expected behaviour.
The filtering doesn't only apply to the beginning of file/folder names, but anywhere in that name. Even more than that, not only the name is targeted, but all displayed attributes (columns). which is nice when you e.g. filter for "image" and have the "Kind" attribute shown. No matter their file extension (if there is any) you'll see all kinds of image files. (BTW, you can AND-link more keywords, just separate them with SHIFT+Spacebar).

comment:6 Changed 5 years ago by dillcn

Sorry for the mistake. In this way, I can't reproduce the problems I mentioned in this bug report now.

comment:7 in reply to:  6 ; Changed 5 years ago by rexmorgan

Replying to dillcn:

Sorry for the mistake. In this way, I can't reproduce the problems I mentioned in this bug report now.

Is this still an issue, then? The original bug report makes it sound like opening the folder automatically has a filter set that is hiding all files/folder within the directory. If that's no longer an issue, we should close this ticket.

comment:8 in reply to:  7 Changed 5 years ago by dillcn

Replying to rexmorgan:

Is this still an issue, then? The original bug report makes it sound like opening the folder automatically has a filter set that is hiding all files/folder within the directory. If that's no longer an issue, we should close this ticket.

I think the problems I mentioned in this bug report still exist.There are two error:

  1. The os automatically hide all folders because a 'block'/'rectangle' character is entered by default, and there are no matched folder names with this character. May be it's an error of VMware, or effect of some unrecognized East Asia characters. See attachment: haiku-nightly-hrev46455-x86gcc2hybrid-vmware.png
  2. Filtering error. See attachment: Enable type-ahead filtering ERROR.png

I have met these errors twice, but they can not be reproduced on purpose. You can close this report at the moment, we can reopen it if someone confirm these errors.

comment:9 Changed 5 years ago by pulkomandy

Resolution: no change required
Status: newclosed

Ok, assuming closed then. Please reopen if you can reproduce.

Note: See TracTickets for help on using tickets.