Opened 5 years ago

Closed 12 months ago

#10284 closed bug (fixed)

Bison crashes when building cross tools x86_64

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

run./configure --build-cross-tools x86_64 ../buildtools/ Bison causes crash and debugger output

Attachments (2)

bison-25474-debug-07-12-2013-01-38-43.report (7.2 KB) - added by vidrep 5 years ago.
bison-50452-debug-07-12-2013-04-37-27.report (7.2 KB) - added by vidrep 5 years ago.
2nd debug report

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by vidrep

comment:1 Changed 5 years ago by bonefish

Platform: Allx86-64

The crashing instruction is rep movsb. RDI contains 0x0000ffcdc3810987, which is an address not covered by an area (don't know why a general protection fault instead of a page fault is generated). The RCX value (0xffff801900000001) doesn't look too good either.

Is this reproducible?

comment:2 Changed 5 years ago by vidrep

It crashed at the same point twice before I submitted the ticket.

comment:3 Changed 5 years ago by vidrep

Attach second debug report after 2 more crashes

Changed 5 years ago by vidrep

2nd debug report

comment:4 Changed 5 years ago by luroh

Milestone: R1Unscheduled

Moving non-x86 related tickets out of R1 milestone.

comment:5 Changed 3 years ago by vidrep

Is this ticket valid anymore?

comment:6 Changed 13 months ago by vidrep

Now that 64 bit is an official R1 build, shouldn't we move it back to R1 milestone?

comment:7 Changed 12 months ago by vidrep

hrev51987 x86_64

make[1]: Leaving directory '/boot/home/haiku/generated/cross-tools-x86_64-build/gcc'

binutils and gcc for cross compilation have been built successfully!

Configured successfully!

~/haiku>

Looks like it's fixed. Closing.

comment:8 Changed 12 months ago by vidrep

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.