Opened 5 years ago

Closed 5 years ago

#10294 closed bug (fixed)

WebPositive doesn't generate history for searches

Reported by: Kev Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On hrev46508:

1) Open Web+ 2) Type a search query in the location bar and hit Enter 3) Click a search result

The back button is still disabled, and the search doesn't appear in the history either, so there's no way to go back to the results if you don't like the first link you click.

Temporary workaround: open result links in new tabs

Change History (4)

comment:1 Changed 5 years ago by Kev

I guess this is sort of fixed as of hrev46756, except that now when you hit Enter your query gets erased and you're taken to the home page of a search engine but without your query.

Last edited 5 years ago by Kev (previous) (diff)

comment:2 Changed 5 years ago by pulkomandy

Make sure your search string in preferences is correct. You need to have "%s" somewhere in the string, and this will be replaced with the search query. for Google, this should be http://www.google.com/search?q=%s

Old versions of WebPositive had http://www.google.com/ as the search string. I added a special check to fix the settings file in this case, but if you had modified the string, there's nothing I can do to automatically fix it.

Moreover, this is not fixed, I still get the problem here. But, I'm currently working on something that may solve the problem.

comment:3 Changed 5 years ago by Kev

Ah, I didn't know the %s was ready. I just tried it and it works great.

Interestingly, on a not-fresh tab, it seems to gobble a history entry too:

a) go to url 1 b) click a link to url 2 c) type a search term in the bar and hit enter d) click back e) you are brought to url 1...url 2 is no longer in the history (at least the forward-back history...)

comment:4 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.