Opened 6 years ago

Closed 6 years ago

#10333 closed bug (duplicate)

Webpositive broken on ebay and other sites

Reported by: SeanCollins Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

also got a crash report, but new webpositive is broken pretty badly on ebay, which is strange, becuase old webkit versions of webpositive while slow, worked on ebay just fine.

ebay.com www.forums.bimmerforums.com

webpositivie is also problematic on various messgae forums. not sure what the exact problems are, but I figured a tracking ticket could suffice, delete if a duplicate.

the crash may or may not be related to rendering and action issues.

issues noted on ebay, naviagation is unresponsive, requiring multiples inputs and frequently failing to respond, same for most forums.

Attachments (1)

WebPositive-1846-debug-21-12-2013-03-27-46.report (53.3 KB) - added by SeanCollins 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by SeanCollins

comment:1 Changed 6 years ago by jscipione

This crash report looks similar to the one in http://dev.haiku-os.org/ticket/8390 perhaps they are related?

comment:2 Changed 6 years ago by pulkomandy

I don't think so. Crashes in malloc in both cases, while creating a BString. Obviously, malloc shouldn't crash, it should either return some memory or NULL.

This points to the heap being corrupted.

Now, we have to find the cause of the memory corruption, which may be completely unrelated to what we see in the backtrace. The best way to do this is to reproduce the crash while using libroot_debug.so, so the crash happens earlier and we get a backtrace of the actual place where the corruption happens.

comment:3 Changed 6 years ago by kallisti5

Resolution: duplicate
Status: newclosed

marking this a duplicate of #9396

Note: See TracTickets for help on using tickets.