Opened 6 years ago

Closed 3 years ago

#10347 closed bug (duplicate)

system slow and freezing with MS Comfort Mouse

Reported by: vidrep Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB/EHCI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Installed 46601 to hard drive. MS comfort mouse model 1478 caused extremely slow performance and at least one freeze of the system. Swapped in an older MS basic optical mouse (USB) restored normal functions.

Attachments (28)

syslog_dev (44.4 KB ) - added by vidrep 6 years ago.
syslog_dev.old (512.0 KB ) - added by vidrep 6 years ago.
syslog_64 (249.0 KB ) - added by vidrep 6 years ago.
syslog (184.2 KB ) - added by vidrep 6 years ago.
syslog.old (512.1 KB ) - added by vidrep 6 years ago.
log.zip (91.0 KB ) - added by vidrep 6 years ago.
log2.zip (86.8 KB ) - added by vidrep 6 years ago.
listdev (3.1 KB ) - added by vidrep 6 years ago.
syslog.2.old (512.0 KB ) - added by vidrep 6 years ago.
syslog.2 (188.5 KB ) - added by vidrep 6 years ago.
syslog.3.old (512.1 KB ) - added by vidrep 6 years ago.
syslog.3 (53.9 KB ) - added by vidrep 6 years ago.
listdev.2 (3.9 KB ) - added by vidrep 6 years ago.
syslog.4 (125.5 KB ) - added by vidrep 5 years ago.
09_11_2014 syslog
HP_dc5750_gcc2_hybrid_serial.txt (112.5 KB ) - added by vidrep 5 years ago.
09_11_2014 serial debug
listdev.3 (2.5 KB ) - added by vidrep 5 years ago.
09_11_2014 listdev
listusb (7.8 KB ) - added by vidrep 5 years ago.
listdev_HP8100 (2.1 KB ) - added by vidrep 5 years ago.
listusb.2 (7.8 KB ) - added by vidrep 4 years ago.
syslog.5 (134.3 KB ) - added by vidrep 4 years ago.
usb_hid_report_descriptor_045e_00db_0.bin (60 bytes ) - added by vidrep 4 years ago.
usb_hid_report_descriptor_045e_00db_1.bin (86 bytes ) - added by vidrep 4 years ago.
usb_hid_report_descriptor_045e_077d_0.bin (364 bytes ) - added by vidrep 4 years ago.
listusb_PC2 (5.8 KB ) - added by vidrep 4 years ago.
syslog_PC2 (327.7 KB ) - added by vidrep 4 years ago.
usb_hid_report_descriptor_045e_00db_0.2.bin (60 bytes ) - added by vidrep 4 years ago.
usb_hid_report_descriptor_045e_00db_1.2.bin (86 bytes ) - added by vidrep 4 years ago.
usb_hid_report_descriptor_045e_077d_0.2.bin (364 bytes ) - added by vidrep 4 years ago.

Change History (53)

comment:1 by anevilyak, 6 years ago

Component: - GeneralDrivers/USB
Owner: changed from nobody to mmlr

A syslog from during the time it's behaving this way would be interesting. Also, can you verify that this behavior is in fact x86_64-specific, or does it occur with a 32-bit build as well?

comment:2 by vidrep, 6 years ago

I did a fresh install of 46601 x86_64 using the MS Comfort Mouse. Attached are the syslog_64 and syslog_64.old files from that install. I then did the same on my other PC for hrev46601_dev. In that case there was no mouse function whatsoever, and the system froze. Attached are the syslog_dev and syslog_dev.old for that PC.

by vidrep, 6 years ago

Attachment: syslog_dev added

by vidrep, 6 years ago

Attachment: syslog_dev.old added

by vidrep, 6 years ago

Attachment: syslog_64 added

comment:3 by vidrep, 6 years ago

The syslog files for the x86_64 are corrupt. I'll upload a new set.

comment:4 by vidrep, 6 years ago

I did a fresh x86_64 install on another PC using the MS Comfort Mouse. On this PC there is no mouse function whatsoever. Attached are the syslog files for this install.

by vidrep, 6 years ago

Attachment: syslog added

by vidrep, 6 years ago

Attachment: syslog.old added

comment:5 by vidrep, 6 years ago

I managed to get the syslogs from the first PC copied without corruption. They are in the attached zip files.

by vidrep, 6 years ago

Attachment: log.zip added

by vidrep, 6 years ago

Attachment: log2.zip added

comment:6 by vidrep, 6 years ago

Fresh install of hrev46656_x86_64. Attached are syslogs and listdev. Confirmed mouse does not currently work with any Haiku version.

by vidrep, 6 years ago

Attachment: listdev added

by vidrep, 6 years ago

Attachment: syslog.2.old added

by vidrep, 6 years ago

Attachment: syslog.2 added

comment:7 by vidrep, 6 years ago

Installed hrev46706_x86_64. Comfort mouse works with this system chipset, but is slow and requires multiple mouse clicks before action. Attach syslog and syslog.old for this installation. Mouse has no function whatsoever on my other PC (HP Elite 8000 SFF)using Intel Q45 chipset.

by vidrep, 6 years ago

Attachment: syslog.3.old added

by vidrep, 6 years ago

Attachment: syslog.3 added

by vidrep, 6 years ago

Attachment: listdev.2 added

comment:8 by korli, 6 years ago

You confirm it is not x86_64 specific?

comment:9 by vidrep, 6 years ago

I have two PC with Haiku. On the HP Elite 8000 there is no mouse function with any version of Haiku. On my HP xw9400 workstation there is mouse function, but it is very slow.

in reply to:  9 comment:10 by umccullough, 6 years ago

Replying to vidrep:

I have two PC with Haiku. On the HP Elite 8000 there is no mouse function with any version of Haiku. On my HP xw9400 workstation there is mouse function, but it is very slow.

Korli's question was whether it works any differently with 32bit Haiku - or is it only slow with 64bit Haiku?

comment:11 by vidrep, 6 years ago

R1/alpha 4.1, 32 bit dev and 64 bit behave the same when installed on the same PC (HP Elite 8000)- no mouse functions.

comment:12 by vidrep, 6 years ago

Currently I only have 64 bit on my HP workstation (xw9400). I'll install 32 bit when I go home tonight, and report on whether it has mouse functions (very slow), same as 64 bit, on that PC.

comment:13 by vidrep, 6 years ago

Installed 32 bit on my workstation. Mouse is slow, same as 64 bit. Since different PC exhibits different behavior, this may be a driver issue.

comment:14 by vidrep, 5 years ago

Installed hrev47851_gcc2_hybrid on HP dc5750 sff PC. Microsoft comfort mouse 6000 model 1478 has no functions. Attached is the syslog and serial debug output.

by vidrep, 5 years ago

Attachment: syslog.4 added

09_11_2014 syslog

by vidrep, 5 years ago

09_11_2014 serial debug

by vidrep, 5 years ago

Attachment: listdev.3 added

09_11_2014 listdev

comment:15 by luroh, 5 years ago

Summary: 46601 x86_64 slow and freezing with MS Comfort Mousesystem slow and freezing with MS Comfort Mouse

comment:16 by vidrep, 5 years ago

This mouse still doesn't work on the latest builds on my new PC - LED lights, but no functions. Standard USB mouse works fine.

comment:17 by vidrep, 5 years ago

I have attached a "listusb" and a "listdev_8100" for the current PC I tried this mouse with. LED lights, but no functions whatsoever. This is using current revision hrev48301 x86_gcc2.

by vidrep, 5 years ago

Attachment: listusb added

by vidrep, 5 years ago

Attachment: listdev_HP8100 added

comment:18 by vidrep, 5 years ago

Tried this mouse again today on hrev49046 x86_gcc2. As before, LED lights up, but no functions whatsoever. Is there any further data I can provide to help resolve this ticket?

comment:19 by vidrep, 4 years ago

Pulkomandy, Attached are a fresh set of logs from my main testing PC using the non-functional Microsoft mouse we discussed on IRC yesterday. hrev49850 x86_gcc2 HP Compaq 8100 Elite SFF PC Microsoft Comfort Mouse 6000 Model 1478 syslog (attached) listusb (attached) USB_HID_report(s) attached

by vidrep, 4 years ago

Attachment: listusb.2 added

by vidrep, 4 years ago

Attachment: syslog.5 added

comment:20 by pulkomandy, 4 years ago

Component: Drivers/USBDrivers/USB/EHCI

According to listusb, the first two HID reports (for device 045e:00db) are for your keyboard. I assume the mouse is 045e:077d, so the 3rd report would be for it.

In the syslog I see these errors, which can be related:

KERN: usb error ehci -1: KERN: qtd (0x4b37480) error: 0x00038d52
KERN: usb error ehci -1: KERN: qtd (0x4b39900) error: 0x00038d52
KERN: usb error ehci -1: qtd (0x4b39a80) error: 0x00038d52
KERN: usb error ehci -1: KERN: qtd (0x4b39c00) error: 0x00038d52

comment:21 by vidrep, 4 years ago

My second Haiku desktop PC behaves somewhat differently with that same mouse, in that there is mouse function, but extremely slow and jerky. I haven't booted into that PC in some weeks (or months), but if it would be helpful, I can provide a syslog, listusb, and HID reports from that one as well.

comment:22 by pulkomandy, 4 years ago

The listusb output and HID reports will (hopefully) be the same, as the mouse seems to be detected. The problem is probably when getting the events from the mouse, maybe similar to #7651.

The attached listusb shows the mouse plugged to an EHCI controller + rate matching hub (this is a modern implementation of USB2), something that could be interesting is trying it on a machine with UHCI or OHCI ports (USB1), but these are hard to come by these days.

comment:23 by vidrep, 4 years ago

Pulkomandy,

I did a fresh install of Haiku 49852 x86_gcc2 and x86_64 on the second PC. The mouse does work on this PC, but requires multiple mouse clicks before any input is registered. Scrolling with the wheel is similarly affected. Mouse speed moving on the desktop appears normal - not slow and jerky as I observed on earlier Haiku builds. listusb_PC2(attached) syslog_PC2 (attached) usb_HID_report(s) (attached)

by vidrep, 4 years ago

Attachment: listusb_PC2 added

by vidrep, 4 years ago

Attachment: syslog_PC2 added

comment:24 by vidrep, 4 years ago

Is there anything in the attached reports and logs that would suggest a possible course of action on my part to resolve the issue?

comment:25 by vidrep, 3 years ago

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.