Opened 6 years ago

Closed 4 years ago

#10369 closed bug (invalid)

Fix Coverity CID 991754: unused pointer value

Reported by: noryb009 Owned by: nobody
Priority: low Milestone: R1
Component: Drivers/Network Version: R1/Development
Keywords: gci2013 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Attachments (1)

0001-Coverity-CID-991754-fix-unused-pointer-value.patch (1001 bytes) - added by noryb009 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by noryb009

Has a Patch: set

comment:2 Changed 6 years ago by umccullough

Technically, this is borrowed FreeBSD code - so the issue is really upstream. We could, however, send the patch upstream I suppose.

comment:3 Changed 6 years ago by noryb009

Would you like me to do so?

comment:4 Changed 6 years ago by umccullough

Sure!

I don't have any clue what the process of upstreaming fixes to FreeBSD is, unfortunately.

Also, they do use Coverity Scan as well - so it's likely they have their own report of this issue lurking in there somewhere.

comment:5 Changed 6 years ago by noryb009

It looks like the function has had a few changes upstream, including the equivalent of the patch: http://svnweb.freebsd.org/base/head/sys/dev/vge/if_vge.c?view=markup#l2022

Last edited 6 years ago by noryb009 (previous) (diff)

comment:6 Changed 5 years ago by umccullough

Priority: normallow

This fix probably should be obtained from upstream then.

comment:7 Changed 5 years ago by umccullough

Has a Patch: unset

comment:8 Changed 4 years ago by waddlesplash

Resolution: invalid
Status: newclosed

A couple people are poking at a FreeBSD drivers upgrade; no need to let this sit around until they do so just to get forgotten...

Note: See TracTickets for help on using tickets.