Opened 6 years ago

Closed 6 years ago

#10372 closed bug (invalid)

Wireless not working with hrev46632 on Asus Eee PC 701

Reported by: Cypress Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/Development
Keywords: wps_supplicant, wireless Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Just installed hrev46632 GCC2 hybrid on my Asus Eee PC 701 ad the Wireless is not working. I'd be happy to provide more info (debug oututs and whatnot) if I knew how.

Attachments (2)

syslog.txt (250.1 KB) - added by umccullough 6 years ago.
syslog
network problem.jpg (104.1 KB) - added by umccullough 6 years ago.
network problem

Download all attachments as: .zip

Change History (13)

comment:1 Changed 6 years ago by anevilyak

The output of the listdev Terminal command, as well as a copy of syslog would be interesting for a start.

comment:2 Changed 6 years ago by Cypress

~> listdev

device Serial bus controller (SMBus) [c|5|0]
  vendor 8086: Intel Corporation
  device 266a: 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller

device Mass storage controller (IDE interface) [1|1|80]
  vendor 8086: Intel Corporation
  device 2653: 82801FBM (ICH6M) SATA Controller

device Bridge (ISA bridge) [6|1|0]
  vendor 8086: Intel Corporation
  device 2641: 82801FBM (ICH6M) LPC Interface Bridge

device Bridge (PCI bridge, Subtractive decode) [6|4|1]
  vendor 8086: Intel Corporation
  device 2448: 82801 Mobile PCI Bridge

device Serial bus controller (USB controller, EHCI) [c|3|20]
  vendor 8086: Intel Corporation
  device 265c: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 265b: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 265a: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2659: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2

device Serial bus controller (USB controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 2658: 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1

device Network controller (Ethernet controller) [2|0|0]
  vendor 168c: Qualcomm Atheros
  device 001c: AR242x / AR542x Wireless Network Adapter (PCI-Express)

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2664: 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3

device Network controller (Ethernet controller) [2|0|0]
  vendor 1969: Qualcomm Atheros
  device 2048: Attansic L2 Fast Ethernet

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2662: 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 2660: 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1

device Multimedia controller (Audio device) [4|3|0]
  vendor 8086: Intel Corporation
  device 2668: 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller

device Display controller [3|80|0]
  vendor 8086: Intel Corporation
  device 2792: Mobile 915GM/GMS/910GML Express Graphics Controller

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 8086: Intel Corporation
  device 2592: Mobile 915GM/GMS/910GML Express Graphics Controller

device Bridge (Host bridge) [6|0|0]
  vendor 8086: Intel Corporation
  device 2590: Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller
Last edited 6 years ago by umccullough (previous) (diff)

comment:3 Changed 6 years ago by Cypress

syslog attached

Last edited 6 years ago by umccullough (previous) (diff)

comment:4 in reply to:  3 Changed 6 years ago by umccullough

Ugh... probably should have uploaded that as a file attachment.

It definitely seems to be detected - do you see it in /dev/net?

How about ifconfig?

I assume you also tried clicking the little network icon on the deskbar to choose an SSID...

comment:5 Changed 6 years ago by Cypress

Couldn't figure out how to attach a file. Anyways, here's the ifconfig output, the contents of /dev/net and the options the networking icon gives me:

network problem

Last edited 6 years ago by umccullough (previous) (diff)

comment:6 Changed 6 years ago by umccullough

There should be an attach file button under the ticket description section, but anyhow.

Did you run the install-wifi-firmwares.sh script? You won't need to, but I thought I'd ask in case that has caused some issue.

Anyhow, I had something similar happen to be the other day - while I was getting constant wpa_supplicant crashes and then messing around with the keystore database and the firmwares script. I forget what I ended up doing to fix the problem, I'm pretty sure I removed the firmware package and reinstalled it, then deleted the keystore database and recreated it, and perhaps I also deleted the network config.

Changed 6 years ago by umccullough

Attachment: syslog.txt added

syslog

Changed 6 years ago by umccullough

Attachment: network problem.jpg added

network problem

comment:7 Changed 6 years ago by Cypress

I installed the latest nightly build on top of alpha4. I ran the wifi firmware script when i installed alpha 4 (I think, as of what I remember). I'll try running it again and if it doesn't do anything I'l try to reproduce your steps.

comment:8 Changed 6 years ago by umccullough

I definitely wouldn't try installing any nightly on top of previous alphas at this point... there have been MAJOR changes to the directory structures and internal design with package management and I would guess the behavior would be very unpredictable.

Also, atheros doesn't require the firmware script.

I recommend a fresh install, or at least booting from something like USB stick or CD to see if it works that way in a clean environment.

comment:9 Changed 6 years ago by Cypress

I'll try booting form USB Stick again, see if it works that way. Thanks for the tip - didn't think of that before.

comment:10 Changed 6 years ago by Cypress

You were right. I wiped the partition and reinstaled a fresh copy of Haiku. WiFi is now working so this bug report can now be closed.

comment:11 Changed 6 years ago by diver

Resolution: invalid
Status: newclosed

Thanks for the note!

Note: See TracTickets for help on using tickets.