Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#1040 closed enhancement (fixed)

.pkg-compatible package installer

Reported by: wkornewald Owned by: sil2100
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

We need an installer that can handle .pkg files, so Haiku users can install old applications. This should be a simple one-click installer.

Change History (4)

comment:1 by axeld, 12 years ago

Owner: changed from axeld to sil2100

comment:2 by scottmc, 11 years ago

Isn't this one complete now? Although it's not listed in the Leaf menu, but the PackageInstaller is in the /boot/beos/apps folder, and seems to work as required.

comment:3 by stippi, 11 years ago

Resolution: fixed
Status: newclosed

Yes, this one is fixed with last year's successful GSoC project. Maybe the Package installer GUI could be beefed up a bit, but it works. Compatibility problems with individual packages should be reported separately I guess. Or maybe if there is a certain type of packages or a certain feature which is not supported.

comment:4 by sil2100, 11 years ago

It seems I forgot about this ticket completely. The installer still needs some work, since there are features that need to be implemented (handling script files in packages, for instance). But that are not really critical for legacy packages installation right now ;-) Separate tickets for compatibility problems is a good idea.

Note: See TracTickets for help on using tickets.