Opened 6 years ago

Closed 5 years ago

#10401 closed bug (fixed)

Debugger creates 0 byte files

Reported by: vidrep Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Debugger Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When saving debug report, often times a 0 byte file is created which cannot be opened .

Attachments (7)

AboutSystem-586-debug-11-01-2014-17-03-25.report (9.6 KB) - added by vidrep 6 years ago.
screenshot3.png (83.0 KB) - added by vidrep 6 years ago.
AboutSystem-1191-debug-11-01-2014-17-12-55.report (9.7 KB) - added by vidrep 6 years ago.
screenshot4.png (82.1 KB) - added by vidrep 6 years ago.
AboutSystem-759-debug-11-01-2014-22-07-51.report (18.6 KB) - added by vidrep 6 years ago.
screenshot4.2.png (76.3 KB) - added by vidrep 6 years ago.
screenshot1.png (83.0 KB) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (20)

Changed 6 years ago by vidrep

Attachment: screenshot3.png added

Changed 6 years ago by vidrep

Attachment: screenshot4.png added

comment:1 Changed 6 years ago by vidrep

Filetype is not recognised by the system, but appears normal when attachment opened in browser.

comment:2 Changed 6 years ago by anevilyak

Sounds like you're simply trying to open them too quickly ; it can take some time to retrieve the information that gets written into the report, depending on the size/complexity of the team being reported on, and the speed of your system, so it's entirely possible for the file to be 0 bytes for a few seconds after creation. While it's 0 bytes, there's no data there for the system to recognize its type by, hence the error message you're seeing. This goes hand in hand with the fact that the files you've attached to this ticket are in fact not 0 bytes, and look like normal/complete reports.

comment:3 Changed 6 years ago by vidrep

I have been seeing this for awhile now. Either the debug report appears as a StyledEdit file on the desktop or as one not recognized by the system. Sometimes they are 0 byte, although the examples I attached this time are not. When I get one of those I'll attach it.

comment:4 Changed 6 years ago by vidrep

I unzipped hrev46656 and installed to a fresh initialized hard drive partition. After opening "about system" the debugger activates. Saved the debug report and waited several minutes before trying to open ( as per suggestion). System does not recognise this file type (same as before). See attached.

Changed 6 years ago by vidrep

Attachment: screenshot4.2.png added

comment:5 Changed 6 years ago by diver

Component: - GeneralApplications/Debugger
Owner: changed from nobody to anevilyak

comment:6 Changed 5 years ago by vidrep

Tried to attach 0 byte debug report generated from hrev46900_x86_64, but trac does not accept 0 byte files for upload. See screenshot instead.

Last edited 5 years ago by vidrep (previous) (diff)

Changed 5 years ago by vidrep

Attachment: screenshot1.png added

comment:7 in reply to:  6 Changed 5 years ago by umccullough

Replying to vidrep:

Tried to attach 0 byte debug report generated from hrev46900_x86_64, but trac does not accept 0 byte files for upload. See screenshot instead.

Yeah, I can't see how a 0 byte file would help anyone determine what's going on anyway - I think we can just take your word for it that it did what you say it did in that case :)

comment:8 Changed 5 years ago by vidrep

Is there any other way of capturing data that might be useful in determining why this is happening? If you have some suggestions, let me know and I'll give them a try.

Last edited 5 years ago by vidrep (previous) (diff)

comment:9 Changed 5 years ago by anevilyak

Realistically the best thing would be a reliable set of steps that causes this to happen so one of us can do so on our systems and analyze it. Do you only see the 0 byte behavior on x86-64 or on all architectures?

comment:10 Changed 5 years ago by vidrep

Currently Webpositive is not working on 64 bit, so generating a debug report is easy. Keep trying to open Webpositive, and eventually you should get a 0 byte report from the debugger. I don't recall this happening on 32 bit, but that could be because it doesn't crash as much. If it happens on 32 bit, I'll definitely take note and update this ticket.

Last edited 5 years ago by vidrep (previous) (diff)

comment:11 Changed 5 years ago by anevilyak

Is this still reproducible with the latest revisions? Report writing has been reworked in the meantime due to another issue that was found.

comment:12 Changed 5 years ago by vidrep

I haven't seen this issue for a while now. I assume it has been fixed. However, I will reopen the ticket if it occurs again.

comment:13 Changed 5 years ago by anevilyak

Resolution: fixed
Status: newclosed

Thanks for the update!

Note: See TracTickets for help on using tickets.