Opened 5 years ago

Closed 19 months ago

#10420 closed enhancement (no change required)

3dfx ati neomagic s3 missing in x86_64 builds

Reported by: vidrep Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Graphics Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by umccullough)

3dfx ati neomagic s3 are missing from the x86_64 images due to pointer size issues

Attachments (2)

listdev (3.1 KB) - added by vidrep 5 years ago.
syslog1 (364.4 KB) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (16)

Changed 5 years ago by vidrep

Attachment: listdev added

Changed 5 years ago by vidrep

Attachment: syslog1 added

comment:1 Changed 5 years ago by vidrep

Confirmed hrev46791_x86_64 Intel Extreme driver is working at 1920x1080 resolution. Nvidia and Ati/AMD cards still using 4:3 VESA modes.

Last edited 5 years ago by vidrep (previous) (diff)

comment:2 Changed 5 years ago by kallisti5

Summary: Only VESA 4:3 video support in x86_64 buildsnivida and radeon_hd drivers missing in x86_64 builds

renaming issue, 4:3 really has nothing to do with this issue.

comment:3 Changed 5 years ago by kallisti5

Summary: nivida and radeon_hd drivers missing in x86_64 buildsnvida and radeon_hd drivers missing in x86_64 builds

comment:4 Changed 5 years ago by kallisti5

Owner: changed from nobody to kallisti5
Status: newassigned

comment:5 Changed 5 years ago by kallisti5

Description: modified (diff)
Summary: nvida and radeon_hd drivers missing in x86_64 builds3dfx ati neomagic s3 missing in x86_64 builds
Type: bugenhancement

added a bunch of cards into hrev46794.

The only video drivers missing from x86_64 now are 3dfx ati neomagic s3. If you have issues with the added drivers, please open new issues for each one. Transforming this issue to "3dfx ati neomagic s3 missing from x86_64"

comment:6 Changed 5 years ago by kallisti5

Owner: changed from kallisti5 to nobody

comment:7 Changed 5 years ago by umccullough

I'm not sure it makes sense to add drivers for cards that were made that long ago (3dfx, s3, etc.) - I seriously doubt anyone who plans to run a 64bit Haiku will still be using those cards - especially since some of them probably pre-date 64bit CPUs ;)

comment:8 Changed 5 years ago by umccullough

Description: modified (diff)

Also, probably not a great idea to adjust the summary/description as you partially fix the issue - it severely reduces the readability of the ticket later on.

There's a "strikethrough" feature you could use in the description text though to represent pieces that are no longer broken.

comment:9 Changed 5 years ago by umccullough

Description: modified (diff)

bah, and now i've made a mess, sorry

comment:10 Changed 5 years ago by vidrep

Excuse me for interjecting with a comment. Going forward, AMD, Nvidia, Matrox and Intel is probably all that is needed right now. No point including legacy hardware drivers for a future 64 bit OS.

comment:11 in reply to:  10 Changed 5 years ago by Premislaus

Replying to vidrep:

Excuse me for interjecting with a comment. Going forward, AMD, Nvidia, Matrox and Intel is probably all that is needed right now. No point including legacy hardware drivers for a future 64 bit OS.

3dfx is well documented. Other 64-bit platforms can still have AGP; Alpha, MIPS, PowerPC, Sparc.

I am convinced that there are motherboards for example Athlon 64 that have AGP. Some of the 3dfx accelerators uses PCI, which is still assembled in the latest motherboards.

comment:12 Changed 5 years ago by umccullough

Is that enough reason to hack on the driver without knowing if it actually works? Who is testing these older cards on 64bit Haiku? Why include potentially broken drivers in x86_64 Haiku that nobody is even using, or likely to use?

I suggest we wait until someone actually has such hardware and willing to test it before we spend time fixing them and including them in the image blindly.

comment:13 Changed 5 years ago by pulkomandy

Component: - GeneralDrivers/Graphics
Milestone: R1Unscheduled

x86_64 - moving out of R1.

comment:14 Changed 19 months ago by waddlesplash

Resolution: no change required
Status: assignedclosed

Indeed; closing as no change required, if someone finds an x64 machine with these cards then they should open a new ticket.

Note: See TracTickets for help on using tickets.