Opened 6 years ago

Closed 6 years ago

#10455 closed bug (fixed)

WebPositive: localization problem on settings window

Reported by: dsjonny Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #10474
Has a Patch: no Platform: All

Description

Using hrev46726 (with WebPositive 1.2.3) some settings are truncated when the language is other than English:

I have checked it with Hungarian and Deutsch language. In English it is OK.

Attachments (3)

webpositivesettings.png (36.3 KB) - added by dsjonny 6 years ago.
screenshot1.png (118.1 KB) - added by dsjonny 6 years ago.
screenshot2.png (134.1 KB) - added by dsjonny 6 years ago.

Download all attachments as: .zip

Change History (16)

Changed 6 years ago by dsjonny

Attachment: webpositivesettings.png added

comment:1 Changed 6 years ago by diver

Blocking: 10474 added

comment:2 Changed 6 years ago by bonefish

Can't reproduce with a freshly built hrev46763 image. Tried different languages and different font sizes.

comment:3 Changed 6 years ago by diver

Please see #10474 for another test case.

comment:4 Changed 6 years ago by bonefish

Already did. Looks OK as well.

comment:5 Changed 6 years ago by luroh

Grabbed the latest nightly gcc2h vmdk (hrev46759), booted to desktop in VBox (with default English language selected), launched WebPositive. 'Window -> Settings -> Proxy server' shows truncated text at the top, 'Use proxy server to connect to the intern...'

comment:6 Changed 6 years ago by bonefish

Looks fine here, too. I've only tested a gcc 4 build so far. Maybe it is gcc 2 specific.

comment:7 Changed 6 years ago by luroh

The gcc4 equivalent nightly displays the same problem.

comment:8 Changed 6 years ago by bonefish

Yeah, and my gcc 2 build looks good as well.

comment:9 Changed 6 years ago by luroh

Ok, maybe it's a problem with Matt's build host. I'll do a clean gcc4 build here (gcc2 doesn't have WebPositive) to double check.

comment:10 Changed 6 years ago by pulkomandy

I suspect this to depend more on your system and WebPositive font sizes than on the way the image was built.

Here, with 10px system font size, and 14px font side in Web+, I can't reproduce the issue. From the screenshot, it looks like the sample text on the "fonts" tab is very small or missing, leading to a smaller window (for me, this is the biggest tab and sets the window size).

comment:11 Changed 6 years ago by bonefish

I had DEBUG enabled for src/kits/interface. When disabling it I see the issue as well with both compilers.

comment:12 Changed 6 years ago by dsjonny

This problem is still exists in hrev46759 nightly anyboot.

I have attached 2 screenshots. 1st is with default settings (in English) and the second is with localized (in Hungarian). This problem is exists in MediaPlayer (settings), WebPositive (settings), Local settings, Expander (settings), Screenshot, Terminal (settings).

Changed 6 years ago by dsjonny

Attachment: screenshot1.png added

Changed 6 years ago by dsjonny

Attachment: screenshot2.png added

comment:13 Changed 6 years ago by bonefish

Resolution: fixed
Status: newclosed

Fixed in hrev46770.

Note: See TracTickets for help on using tickets.