Opened 5 years ago

Closed 5 years ago

#10483 closed bug (fixed)

Strange Cursor after start of BePDF(hpkg) and GobeProductive(zip)

Reported by: Morbid Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: #9261 Blocking:
Has a Patch: no Platform: x86

Description

After installation of BePDF via HaikuDepot and starting, the Mouse-Cursor change to a black, opened hand in a white square. Same after GobeProductive unpacking and starting. Not sure if it's a Haiku or an PC problem, cause it's an selfmade one with old hardware parts. I'm using latest nightly hrev46779. Could that repoduced by another one?

Attachments (6)

listdev.txt (1.2 KB) - added by Morbid 5 years ago.
Syslog.txt (226.6 KB) - added by Morbid 5 years ago.
AboutSystem.jpeg (131.2 KB) - added by Morbid 5 years ago.
opened_hand.JPG (65.5 KB) - added by Morbid 5 years ago.
closed_hand.JPG (57.5 KB) - added by Morbid 5 years ago.
nvidia.settings (3.2 KB) - added by humdinger 5 years ago.
"hardcursor false" in ~/config/settings/kernel/drivers/nvidia.settings

Download all attachments as: .zip

Change History (17)

Changed 5 years ago by Morbid

Attachment: listdev.txt added

Changed 5 years ago by Morbid

Attachment: Syslog.txt added

Changed 5 years ago by Morbid

Attachment: AboutSystem.jpeg added

comment:1 Changed 5 years ago by Morbid

At screenshot Mouse-Cursor is normal on picture. Also if i move the Cursor above an opened folder the hand will be closed as long moving around inside. Cursor only goes normal after a restart of Haiku.

Last edited 5 years ago by Morbid (previous) (diff)

Changed 5 years ago by Morbid

Attachment: opened_hand.JPG added

Changed 5 years ago by Morbid

Attachment: closed_hand.JPG added

comment:2 Changed 5 years ago by waddlesplash

IIRC BePDF comes with its own mouse cursors, so this *might* be a BePDF bug. I'll have to look at how BePDF manages it's cursors, though.

Looking at the screenshots, those *are* BePDF's cursors, although I have no idea why they are reversed. This sounds like a graphics driver bug to me.

comment:3 Changed 5 years ago by anevilyak

Could also be a problem with hardware cursor support in whatever graphics driver is in use.

comment:4 Changed 5 years ago by Morbid

Have tried with R1/alpha4.1, too. No Problems there. Starting hrev46779 in failsave mode with resolution 1024x768 at 16bit. Also no Problems.

Last edited 5 years ago by Morbid (previous) (diff)

comment:5 in reply to:  3 Changed 5 years ago by humdinger

Replying to anevilyak:

Could also be a problem with hardware cursor support in whatever graphics driver is in use.

We've talked a bit on IRC today, and it's the nvidia driver. I have the same issues here, but I have a "nvidia.settings" file in ~/config/settings/kernel/drivers/ where I have a line "hardcursor false" (I attach it for people in search of this file). That fixes it for me, but apparently not for Matt.

Anyway, wouldn't it make sense to have "hardcursor false" as default in the driver, so it's working for people having this issue?

Changed 5 years ago by humdinger

Attachment: nvidia.settings added

"hardcursor false" in ~/config/settings/kernel/drivers/nvidia.settings

comment:6 Changed 5 years ago by Morbid

Let me ask one question. Why this not occurs on opening applications like Haiku3d, FontDemo, DeskCalc, People and so on?

comment:7 Changed 5 years ago by anevilyak

Not every app uses custom cursors.

comment:8 Changed 5 years ago by Morbid

Ok. Thanks!

comment:9 Changed 5 years ago by axeld

Since the nvidia driver already worked under BeOS, this is most likely an app_server issue that deserves to be fixed.

comment:10 Changed 5 years ago by axeld

Component: ApplicationsServers/app_server
Owner: changed from nobody to axeld

comment:11 Changed 5 years ago by pulkomandy

Blocked By: 9261 added
Resolution: fixed
Status: newclosed

Duplicate of #9261.

Note: See TracTickets for help on using tickets.