Opened 5 years ago

Closed 4 months ago

#10489 closed bug (fixed)

Web+ crops date column in gmail's standard web interface

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev46574.

See, the year is cut of... "201?":

cut off date column in gmail web interface

Attachments (1)

screenshot2.png (15.5 KB) - added by humdinger 5 years ago.
cut off date column in gmail web interface

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by humdinger

Attachment: screenshot2.png added

cut off date column in gmail web interface

comment:1 Changed 4 years ago by pulkomandy

They are not cut off anymore, but they still draw outside their reserved area. Is the year also using 4 digits on other browsers?

comment:2 in reply to:  1 Changed 4 years ago by humdinger

Replying to pulkomandy:

Is the year also using 4 digits on other browsers?

It is in Firefox under Ubuntu and QupZilla in Haiku.

comment:3 Changed 2 years ago by pulkomandy

Well it seems to fit now that we are using Noto. I suspect the problem is Google hardcodes the column width and expect us to use their font or something similar, and the font we use as a fallback used to be wider than expected?

comment:4 Changed 2 years ago by humdinger

I don't know. In Web+ font settings I use Noto 14pt, because 13pt is much smaller than in the Haiku GUI. Using "View | Increase size" in Web+ will still draw the date outside the column. In Firefox under Linux, increasing the font size like this works, the column width isn't fixed as in Web+.

comment:5 Changed 4 months ago by humdinger

Resolution: fixed
Status: newclosed

Fixed with latest haikuwebkit 1.6.9. Thanks!

Note: See TracTickets for help on using tickets.