Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#10492 closed bug (duplicate)

media_addon_server crash on MediaPlayer playback (in float_to_float())

Reported by: humdinger Owned by: nobody
Priority: normal Milestone: R1
Component: Add-Ons/Media/Mixer Version: R1/Development
Keywords: Cc:
Blocked By: #7180 Blocking:
Has a Patch: no Platform: All

Description

This is hrev46754.

I have another crash, that doesn't seem to have the same backtrace as the half dozen already reported tickets. The debugger report is different to the things recorded in the syslog. Both attached.

The audio mixer uses "Drop/repeat samples" BTW.

Attachments (2)

media_addon_server-689-debug-30-01-2014-16-01-22.report (15.1 KB) - added by humdinger 5 years ago.
the debugger report
syslog.txt (1.6 KB) - added by humdinger 5 years ago.
the syslog of the crash

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by humdinger

the debugger report

Changed 5 years ago by humdinger

Attachment: syslog.txt added

the syslog of the crash

comment:1 Changed 5 years ago by anevilyak

Component: Servers/media_addon_serverAdd-Ons/Media/Mixer
Owner: changed from axeld to nobody

That one looks like a problem in the mixer, the destination buffer passed into Resampler::float_to_float() was NULL.

comment:2 Changed 5 years ago by korli

I'd have said the source buffer.

comment:3 Changed 5 years ago by humdinger

The debugger report is different to the things recorded in the syslog.

I actually misread the debug report... it's the same as the syslog after all. Thanks Rene for getting it straight.

comment:4 in reply to:  2 ; Changed 5 years ago by anevilyak

Replying to korli:

I'd have said the source buffer.

The one it's crashing on dereference for was at 0xc(%ebp), which unless I'm mistaken would be the 4th argument, wouldn't it?

comment:5 in reply to:  4 Changed 5 years ago by korli

Replying to anevilyak:

Replying to korli:

I'd have said the source buffer.

The one it's crashing on dereference for was at 0xc(%ebp), which unless I'm mistaken would be the 4th argument, wouldn't it?

2nd parameter, which, unless I'm mistaken, is the 1st method parameter taking into account the instance.

comment:6 Changed 5 years ago by diver

Blocked By: 7180 added
Resolution: duplicate
Status: newclosed

comment:7 Changed 4 years ago by ttcoder

Summary: media_addon_server crash on MediaPlayer playbackmedia_addon_server crash on MediaPlayer playback (in float_to_float())

If #11497 is any indication, it was korli who was right and the NULL pointer is src, not dest ;-)

<deleted question about which ticket is a duplicate: this ticket is already closed as duplicate of #7180, d'oh!>

Last edited 4 years ago by ttcoder (previous) (diff)
Note: See TracTickets for help on using tickets.