Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10508 closed bug (duplicate)

Terminal does not parse ANSI escapes in a pager, only on standard output

Reported by: tidux Owned by: nobody
Priority: normal Milestone: R1/beta1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: Cc: siarzhuk
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

To reproduce, open any installed manpage with "man". The file is unreadable garbage, with lots of ESC[ characters. If you redirect the output of that "man" command to a file, and then open the file with "cat", Terminal displays it properly. However, this means you lose search and seek and the ability to get readable output from grepping a manpage. Marking this as a Beta 1 bug because unreadable manpages is or should be a blocker for most of our intended userbase. I'm reporting this bug on nightly hrev46791, but I believe it's reproducible all the way back to Alpha 3.

This might also be a bug with our version of "less", since ncurses apps like Tin or w3m work as expected.

Change History (4)

comment:1 by anevilyak, 6 years ago

Cc: siarzhuk added

comment:2 by bonefish, 6 years ago

Component: Applications/TerminalApplications/Command Line Tools
Owner: changed from jackburton to nobody

If you run man ... | less -r the man page looks OK as well. man can actually be configured to invoke less with this switch (in /system/settings/man.conf), but in the man sources one can find a comment that having to do that indicates some kind of misconfiguration. I don't know what that refers to exactly, but I think the first step should be to oursource and update our ancient less.

comment:3 by pulkomandy, 6 years ago

Blocked By: 10086 added
Resolution: duplicate
Status: newclosed

comment:4 by korli, 6 years ago

Blocked By: 10086 removed

(In #10086) Fixed in hrev47124.

Note: See TracTickets for help on using tickets.