Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10540 closed bug (duplicate)

ATI Radeon Xpress 1150 no video

Reported by: vidrep Owned by: euan
Priority: normal Milestone: R1
Component: Drivers/Graphics/radeon Version: R1/Development
Keywords: Cc:
Blocked By: #3177 Blocking:
Platform: All

Description

Installed alpha4.1 and hrev46791 to hard drive partitions. On board ATI Radeon Xpress 1150 (200) graphics is not supported by any driver. Setting screen preferences produces error message (see screenshot).

Attachments (6)

screenshot1.png (37.5 KB ) - added by vidrep 7 years ago.
listdev (3.1 KB ) - added by vidrep 7 years ago.
listimage|grep accel (226 bytes ) - added by vidrep 7 years ago.
listimage|grep drivers (1.6 KB ) - added by vidrep 7 years ago.
syslog (150.3 KB ) - added by vidrep 7 years ago.
IMG_0114.JPG (1.5 MB ) - added by vidrep 7 years ago.

Download all attachments as: .zip

Change History (16)

by vidrep, 7 years ago

Attachment: screenshot1.png added

by vidrep, 7 years ago

Attachment: listdev added

by vidrep, 7 years ago

Attachment: listimage|grep accel added

by vidrep, 7 years ago

Attachment: listimage|grep drivers added

comment:1 by umccullough, 7 years ago

Component: - GeneralDrivers/Graphics
Type: bugenhancement

by vidrep, 7 years ago

Attachment: syslog added

comment:2 by umccullough, 7 years ago

Component: Drivers/GraphicsDrivers/Graphics/radeon
Owner: changed from nobody to euan
Type: enhancementbug

Would recommend trying a nightly, since R1A4.1 is something like 1.5 years old now.

Surprising that the driver loaded, but the accelerant did not... this suggests perhaps that chip isn't fully supported.

comment:3 by vidrep, 7 years ago

In the bug description, hrev46791 had the same result - no video. When trying to boot hrev46791 again in fail safe video mode (800X600 32) it KDL's every time. I'll attach a photo of the hrev46791 KDL output shortly.

by vidrep, 7 years ago

Attachment: IMG_0114.JPG added

comment:4 by umccullough, 7 years ago

I'm confused - are you intentionally choosing failsafe video from the boot menu? If yes, then that probably explains why the radeon accelerant isn't loading.

The KDL you attached doesn't appear to be related to the video driver at all.

Last edited 7 years ago by umccullough (previous) (diff)

comment:5 by vidrep, 7 years ago

KDL output from hrev46791 hybrid attached.

comment:6 by vidrep, 7 years ago

If failsafe mode is not selected there is no video signal on alpha 4.1 or hrev46791 nightly - black screen. I was able to get alpha 4.1 to the installation screen and complete the install to the hard drive by selecting failsafe video mode. Trying the same process with hrev46791 nightly causes a KDL every time.

comment:7 by umccullough, 7 years ago

The KDL in the nightly is unrelated it seems - it's crashing for a different reason, and probably deserves its own ticket.

Choosing a failsafe video mode will likely get you nothing but vesa graphics, which is why you're not seeing the radeon accelerant running, and also why changing the mode is failing.

Either way, it looks like the radeon driver may need to be fixed to properly support your chipset. If you can get a serial output of a boot without setting the failsafe video mode, that might yield some further details (assuming it crashes somewhere else).

comment:8 by vidrep, 7 years ago

Ticket #7662 appears to be related to this problem with many others having reported issues with this same chipset (see #3177). I'll try to get you a serial output of the boot with both builds.

Last edited 7 years ago by vidrep (previous) (diff)

comment:9 by diver, 7 years ago

Blocked By: 3177 added
Resolution: duplicate
Status: newclosed

Indeed, it looks like a dupe of #3177. Closing as such.

comment:10 by vidrep, 7 years ago

Attached serial debug logs to ticket #3177. If KDL on fail safe video is unrelated, I'll open a new ticket.

Note: See TracTickets for help on using tickets.