Opened 7 years ago

Closed 8 months ago

#10551 closed bug (fixed)

AC 97 driver isn´t working anymore on Thinkpad T23

Reported by: ronny Owned by: korli
Priority: normal Milestone: R1/beta3
Component: Drivers/Audio/auich Version: R1/Development
Keywords: AC97 Cc:
Blocked By: Blocking:
Platform: x86

Description

The AC´97 driver isn´t working anymore on my Thinkpad T23.

vendor 8086: Intel Corporation device 2485: 82801CA/CAM AC´97 Audio Controller

Haiku loads the "Auich" driver

No playback possible.

I disabled the Auich driver during boot and took the old AC´97 driver and placed it in:

/boot/home/config/non-packaged/add-ons/kernel/drivers/bin

and the symlink in:

/boot/home/config/non-packaged/add-ons/kernel/drivers/dev/audio/hmulti

Nothing changed.

In 2009 the old AC´97 driver worked for me.

Attachments (1)

syslog (179.5 KB ) - added by ronny 7 years ago.
syslog file Thinkpad T23

Download all attachments as: .zip

Change History (6)

comment:1 by korli, 7 years ago

Please tell which revision is used and provide a syslog. See [ReportingBugs].

by ronny, 7 years ago

Attachment: syslog added

syslog file Thinkpad T23

comment:2 by ronny, 7 years ago

Revision is hrev46860 x86_gcc2

comment:3 by diver, 7 years ago

Component: Audio & VideoDrivers/Audio/auich
Owner: changed from nobody to korli

auich: codec semaphore timed out!

Looks like a dupe of #4491.

comment:4 by mmlr, 8 months ago

Fixed in hrev54505. Please retest and attach a new syslog to confirm if the hardware is still around.

comment:5 by mmlr, 8 months ago

Milestone: R1R1/beta3
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.