Opened 6 years ago

Closed 5 years ago

Last modified 15 months ago

#10565 closed bug (duplicate)

Haiku KDLs right as desktop appears

Reported by: dsuden Owned by: kallisti5
Priority: normal Milestone: R1/beta1
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: #10606 Blocking:
Has a Patch: no Platform: All

Description

I'm having an intermittent problem with crashes at bootup that I really need to solve, and I'm offering a $200 bounty in case someone can solve this for me. Here's the scenario.

I can boot OK an average of about 70 percent of the time, maybe a bit more. But sometimes, just after the desktop and icons appears, I see a row of gold sparkles across the top of the screen for about one second (about 30 pixels tall) and then Haiku KDLs. I have attached a screen grab and can get more of them if it's helpful.

I'm using HREV 46104, one of the last builds before PM, because there are still a few rough edges that keep us from being able to move all our systems builds over to PM. The motherboard is an ASUS F2A55M and it uses an AMD processor. I have tried both IDE emulation and AHCI SATA modes in BIOS and the problem happens with both.

Would be most grateful to have this solved!

Attachments (2)

IMG_2231.JPG (594.6 KB ) - added by dsuden 6 years ago.
KDL happens sometimes at bootup
IMG_2244.JPG (1.2 MB ) - added by dsuden 6 years ago.
list of "ints"

Download all attachments as: .zip

Change History (18)

by dsuden, 6 years ago

Attachment: IMG_2231.JPG added

KDL happens sometimes at bootup

comment:1 by dsuden, 6 years ago

Here's a listdev:

Welcome to the Haiku shell.

/> listdev

device Bridge (Host bridge) [6|0|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 1405: Family 15h (Models 10h-1fh) Processor Function 5

device Bridge (Host bridge) [6|0|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 1404: Family 15h (Models 10h-1fh) Processor Function 4

device Bridge (Host bridge) [6|0|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 1403: Family 15h (Models 10h-1fh) Processor Function 3

device Bridge (Host bridge) [6|0|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 1402: Family 15h (Models 10h-1fh) Processor Function 2

device Bridge (Host bridge) [6|0|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 1401: Family 15h (Models 10h-1fh) Processor Function 1

device Bridge (Host bridge) [6|0|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 1400: Family 15h (Models 10h-1fh) Processor Function 0

device Serial bus controller (USB controller, XHCI) [c|3|30]

vendor 1b21: ASMedia Technology Inc. device 1042: ASM1042 SuperSpeed USB Host Controller

device Bridge (PCI bridge, Normal decode) [6|4|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 43a2: Hudson PCI to PCI bridge (PCIE port 2)

device Network controller (Ethernet controller) [2|0|0]

vendor 10ec: Realtek Semiconductor Co., Ltd. device 8168: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

device Bridge (PCI bridge, Normal decode) [6|4|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 43a1: Hudson PCI to PCI bridge (PCIE port 1)

device Bridge (PCI bridge, Normal decode) [6|4|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 43a0: Hudson PCI to PCI bridge (PCIE port 0)

device Bridge (PCI bridge, Subtractive decode) [6|4|1]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 780f: FCH PCI Bridge

device Bridge (ISA bridge) [6|1|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 780e: FCH LPC Bridge

device Multimedia controller (Audio device) [4|3|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 780d: FCH Azalia Controller

device Mass storage controller (IDE interface) [1|1|8f]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 780c: FCH IDE Controller

device Serial bus controller (SMBus) [c|5|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 780b: FCH SMBus Controller

device Serial bus controller (USB controller, EHCI) [c|3|20]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 7808: FCH USB EHCI Controller

device Serial bus controller (USB controller, OHCI) [c|3|10]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 7807: FCH USB OHCI Controller

device Serial bus controller (USB controller, EHCI) [c|3|20]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 7808: FCH USB EHCI Controller

device Serial bus controller (USB controller, OHCI) [c|3|10]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 7807: FCH USB OHCI Controller

device Mass storage controller (IDE interface) [1|1|8f]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 7800: FCH SATA Controller [IDE mode]

device Multimedia controller (Audio device) [4|3|0]

vendor 1002: Advanced Micro Devices, Inc. [AMD/ATI] device 9902: Trinity HDMI Audio Controller

device Display controller (VGA compatible controller, VGA controller) [3|0|0]

vendor 1002: Advanced Micro Devices, Inc. [AMD/ATI] device 9993: Trinity [Radeon HD 7480D]

device Bridge (Host bridge) [6|0|0]

vendor 1022: Advanced Micro Devices, Inc. [AMD] device 1410: Family 15h (Models 10h-1fh) Processor Root Complex

/>

comment:2 by dsuden, 6 years ago

Just thought of one more thing. The last thing to appear before the sparkles and the KDL is the little popup saying network is ready. May have no bearing, but figured I'd mention it.

ALSO...I have just uploaded a screen grab showing the interrupts listed when I type "ints" into a KDL.

Last edited 6 years ago by dsuden (previous) (diff)

by dsuden, 6 years ago

Attachment: IMG_2244.JPG added

list of "ints"

comment:3 by Coldfirex, 6 years ago

Out of curiosity is this KDL only on one system? If so, have you already ruled out a hardware issue? I had something similar before and it was related to the PSU not being powerful enough and the video card overheating.

comment:4 by korli, 6 years ago

dsuden, could you post a list of "ints" when the system behaves correctly?

comment:5 by dsuden, 6 years ago

Coldfirex, no, this happens on all the systems I'm building, which all use the same kind of hardware.

comment:6 by dsuden, 6 years ago

Hi Korli,

"dsuden, could you post a list of "ints" when the system behaves correctly?"

The ints I posted up there were done with a forced KDL (pntscrn-alt-d) while fully booted up...so they may actually be the "behaves correctly" ones. The next question you're likely to ask is, "can you show me some ints when it's behaving badly...and that's where I've been running into snags this morning. A forced KDL has been the only way I've been able to get any typing to work in the KDL pane, and then, *only* if I let the computer completely boot up first.

With a USB keyboard, I tried the trick where you do prntscrn-alt-d just before the computer finishes booting, then typing continue, but KDL pane doesn't respond when I type continue. I have a screen grab of what it says exactly, but it's something about having received three signals, keyboard requested halt, usb keyboard 2 watcher.

If I try using a PS2 keyboard, the computer spontaeously reboots as soon as I type anything in KDL.

Dane

in reply to:  6 comment:7 by ttcoder, 6 years ago

Replying to dsuden:

If I try using a PS2 keyboard, the computer spontaeously reboots as soon as I type anything in KDL.

That's another bit I find odd (to say the least!).. Confirming, PS2 is not hot-pluggable so you do plug the PS2 keyboard way before, you don't do a "hot plug" at the last minute? (though even that would not make the computer reboot spontaneously me thinks).

For KDL not responding to a USB keyboard, the haiku devs will know better but I seem to recall it depends on the type of USB port you have: maybe try to plug the keyboard into a different port (backplate if you tried front, or vice-versa). If you can't type anything with PS2 or USB keyboards it's going to be hard to track this down :-(

comment:8 by luroh, 6 years ago

Blocking: 7665 added

comment:9 by ttcoder, 6 years ago

This was reportedly caused by the radeon_hd driver.. Removing the driver from that rev46104 install apparently makes the system boot successfully 100% of the time again.

comment:10 by waddlesplash, 5 years ago

Component: - GeneralDrivers/Graphics/radeon_hd
Milestone: R1R1/alpha5
Owner: changed from nobody to kallisti5

There have been a lot of fixes to radeon_hd in the past 4 months, is this still an issue?

comment:11 by ttcoder, 5 years ago

This ticket is either related or a dupe of #10606 it seems: that latter ticket has a recent update on our situation, it shows that as of 4 weeks ago the radeon_hd driver now 'recognizes' the hardware we use (so not sure why radeon_hd acted up 4 months ago since the PCI ID was not even part of it?) but incorrectly so, meaning we'll be forced to configure a blacklist on each shipped system if we use the upcoming alpha5...

comment:12 by pulkomandy, 5 years ago

I removed that ID from the driver again in hrev47640. Let us know if the KDL is back or if things are running properly now.

comment:13 by ttcoder, 5 years ago

Thanks Adrien! I was able to comment out the blacklist entry after updating to this:

~/Desktop> uname -a
Haiku shredder 1 hrev47645 Aug  7 2014 06:33:16 BePC x86 Haiku
~

Ticket can be closed I believe.

Last edited 5 years ago by ttcoder (previous) (diff)

comment:14 by pulkomandy, 5 years ago

Blocked By: 10606 added
Resolution: duplicate
Status: newclosed

comment:15 by pulkomandy, 5 years ago

Milestone: R1/alpha5R1/beta1

comment:16 by waddlesplash, 15 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.