Opened 2 months ago

Closed 8 weeks ago

Last modified 8 weeks ago

#10578 closed bug (fixed)

BView Scaling dont works for font and Rounded Rects

Reported by: Paradoxon Owned by: axeld
Priority: normal Milestone: R1/alpha5
Component: Kits/Interface Kit Version: R1/Development
Keywords: Scale BView Rendering Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Steps to recreate the behavior:
download projectcontor:

  1. http://projectconceptor.de/ProjectConceptor-0.0.6-33-x86_gcc2.hpkg
  2. create a node in Grapheditor
  3. select in the status bar a different scale

This will use all normal drawing method just with a differnt scaling set.
But Fon will be drawn always the same size
also RoundedRect will be drawn always with not scaled round corners

Attachments (2)

Scale_50.png (22.9 KB) - added by Paradoxon 2 months ago.
A Node 50 % scaled
Scale_100.png (24.2 KB) - added by Paradoxon 2 months ago.
Node at normal scale

Download all attachments as: .zip

Change History (6)

Changed 2 months ago by Paradoxon

A Node 50 % scaled

Changed 2 months ago by Paradoxon

Node at normal scale

comment:1 Changed 2 months ago by stippi

Is this some new software, using the new affine transformation support, or old BeOS software?

I can imagine how the radius bug for round rects happens, consider that one confirmed. But the font bug sounds strange, since I definitely tested that.

comment:2 Changed 2 months ago by stippi

This app is either horribly buggy, or it suffers from many more things that are implemented in Haiku in a way which is not compatible with BeOS.

The round-corner issue is at least fixed. How was the .hpkg created? From binaries or source? The source could be helpful in locating the compatibility issues in Haiku.

comment:3 Changed 2 months ago by Paradoxon

The app is horrible buggy :-) at least i can confirm this.. ;-) its a old hobby project written for zeta :-D
source can be found here:
https://code.google.com/p/projectconceptor/source/browse/

The drawing is happening here:
https://code.google.com/p/projectconceptor/source/browse/trunk/src/plugins/GraphEditor/GraphEditor.cpp#338

Wich calls the Renderer of the node
https://code.google.com/p/projectconceptor/source/browse/trunk/src/plugins/GraphEditor/ClassRenderer.cpp#368

Wich calls the String renderer for the name :)
here:
https://code.google.com/p/projectconceptor/source/browse/trunk/src/plugins/GraphEditor/StringRenderer.cpp#74

Its freshly compiled from source but i hacked the hpgk support and the haiku support "fast" together

Last edited 2 months ago by Paradoxon (previous) (diff)

comment:4 Changed 8 weeks ago by stippi

  • Resolution set to fixed
  • Status changed from new to closed
Last edited 8 weeks ago by stippi (previous) (diff)
Note: See TracTickets for help on using tickets.