Opened 5 years ago

Closed 5 years ago

#10645 closed enhancement (fixed)

BView: add support for even/odd winding rule

Reported by: pulkomandy Owned by: stippi
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #10214
Has a Patch: no Platform: All

Description

There are two possible way of filling polygons: the "even/odd" and the "non-zero" rules. Haiku currently uses the "non-zero" rule.

Some drawing code in WebKit requires use of the "even/odd" rule. This is the cause of #10214, and probably some other problems.

It would be nice to add a way to change the winding rule, either as an extra argument to FillPolygon and FillShape, or as part of the view state.

Agg supports both winding rules (with agg::fill_even_odd and agg::fill_non_zero constants). Our custom polygon rasterizer seems to have code for handling this, but I don't know if it works.

Change History (1)

comment:1 Changed 5 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Implemented in hrev47005.

Note: See TracTickets for help on using tickets.