Opened 5 years ago

Closed 5 months ago

#10737 closed bug (not reproducible)

[AHCI error] InterruptErrorHandler

Reported by: pragmavalue Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Hi,

I try to install new nightly hrev47085 on my laptop, and Haiku don't start up. Main problem is with AHCI at you can see on attached picture...

Attachments (2)

2014-04-04 20.16.36.jpg (646.3 KB) - added by pragmavalue 5 years ago.
Error with AHCI
boot-kdl-ahci.txt (10.2 KB) - added by jua 4 years ago.
serial log from boot attempt leading to KDL

Download all attachments as: .zip

Change History (20)

Changed 5 years ago by pragmavalue

Attachment: 2014-04-04 20.16.36.jpg added

Error with AHCI

comment:1 Changed 5 years ago by luroh

Blocking: 7665 added

comment:2 Changed 5 years ago by waddlesplash

What laptop is this?

comment:3 Changed 5 years ago by pragmavalue

Notebook made by Asus. When I slow down a startup by enable on-screen debug and enable paging system startup normally.

comment:4 Changed 5 years ago by diver

Component: DriversDrivers/Disk
Description: modified (diff)

comment:5 Changed 4 years ago by pragmavalue

Probably fixed in hrev49590, please close.

comment:6 Changed 4 years ago by pulkomandy

Resolution: fixed
Status: newclosed

comment:7 Changed 4 years ago by jua

Resolution: fixed
Status: closedreopened

Unfortunately, it's not fixed. Updated to latest packages (hrev49607) today and now I have this problem too, it almost always fails to boot due to AHCI. Sometimes (rarely) it succeeds booting.

Attaching excerpt from serial debug log for a failed boot (shortened, it always outputs just the same AHCI error messages before finally giving up and KDLing).

Changed 4 years ago by jua

Attachment: boot-kdl-ahci.txt added

serial log from boot attempt leading to KDL

comment:8 Changed 4 years ago by jua

To clarify: I never had this problem before, it still worked fine in hrev49327 which I used previously. So the commit which fixed AHCI for some people broke it for others it seems...

comment:9 Changed 4 years ago by jua

Summary: [AHCI error on Asus U32U] InterruptErrorHandler[AHCI error] InterruptErrorHandler

comment:10 Changed 4 years ago by diver

Owner: changed from nobody to mmlr
Status: reopenedassigned

comment:11 Changed 4 years ago by mmlr

Owner: changed from mmlr to nobody

I just fixed the unaligned access due to the wrongly sized bitfield by replacing the field with shifts and masks (which could've been solved by changing to a correctly sized bitfield plus endianness wrapper instead, as Axel mentioned). I have not studied the original concept of the patch nor did I change anything in that regard.

comment:12 Changed 4 years ago by anevilyak

The recent changes broke my previously working AHCI controller as well, with an identical serial log to jua's, in my case venid 0x8086, devid 0x1c02, if relevant.

comment:13 Changed 4 years ago by anevilyak

Owner: changed from nobody to axeld

Assigning to Axel since he reviewed/applied the aforementioned patches.

comment:14 Changed 11 months ago by waddlesplash

Keywords: boot-failure added

comment:15 Changed 11 months ago by waddlesplash

Blocking: 7665 removed

comment:16 Changed 5 months ago by waddlesplash

Still an issue?

comment:17 Changed 5 months ago by pragmavalue

please close.

comment:18 Changed 5 months ago by waddlesplash

Resolution: not reproducible
Status: assignedclosed
Note: See TracTickets for help on using tickets.