Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#10779 closed bug (fixed)

Very low frame rates playing videos streams in webpositive

Reported by: HAL Owned by: jua
Priority: normal Milestone:
Component: Applications/WebPositive Version:
Keywords: low frame rate webpositive video Cc: HAL
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I was playing video streams from youtube and www.space.com which refered the browser to another page. The fps are very low, almost like a slide show. The specific videos played were: http://new.livestream.com/viewnow/explormars and any video from youtube.com. It probably applies to all streaming videos. For anyone testing that web address just a warning: it is a long large download before it starts playing but maybe try other videos from space.com. I was testing in hrev47149 GCC4 hybrid.

Anyway thanks for the great progress pulkomandy. Just to have html5 streaming videos in webpositive.

Change History (7)

comment:1 Changed 5 years ago by HAL

On trying another video from space.com: http://www.space.com/25531-new-earth-size-planet-could-have-water-video.html I found that the frame rate is much better. So some streaming videos do not have low frame rates. I will try and find examples of other reasonably short videos with normal and low fps.

comment:2 Changed 5 years ago by HAL

This video from space.com plays smoothly in a small window. There is no option for full screen. http://brightcove.vo.llnwd.net/e1/pd/1417332051/1417332051_2208194789001_SP-100423-x-37-nasa-boeing.mp4?playerId=975006952001&lineupId=&affiliateId=&pubId=1417332051&videoId=79860462001

This video plays smooth in small window but low fps in fullscreen: http://www.youtube.com/watch?v=dvHv3w6cgJE Some other videos played in a window are low fps though. I cannot list anymore at the moment because for some reason webpositive does not want the play anymore.

comment:3 Changed 5 years ago by HAL

Have not found anymore videos with low fps, in window mode except the link I gave at report discription. They all play low fps in window that takes up full browser or fullscreen.

comment:4 Changed 5 years ago by pulkomandy

I think the problem is scaling of the video to fill the screen, which is done in software. I'll see what I can do to make it faster.

comment:5 Changed 4 years ago by pulkomandy

Owner: changed from pulkomandy to jua
Status: newassigned

This will probably be fixed in HaikuWebKit 1.5.0

comment:6 Changed 4 years ago by jua

Resolution: fixed
Status: assignedclosed

Please check again with hrev49807 or later and reopen the bug ticket if you still see the problem.

Last edited 4 years ago by jua (previous) (diff)

comment:7 Changed 4 years ago by HAL

I checked with hrev49834 but unable to verify as fullscreen is not working anymore in WebPositive. I was doing the testing with hrev49834 x86 64 as the sound in the same revision with gcc2 has become distorted.

Last edited 4 years ago by HAL (previous) (diff)
Note: See TracTickets for help on using tickets.