Opened 5 years ago

Closed 5 years ago

#10792 closed bug (no change required)

Windows with default button handle keyboard incorrectly

Reported by: KapiX Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

Steps to reproduce:

  1. Open any window with default button (i.e. Backgrounds preflet).
  2. Select desired button with Tab (it highlights with blue color).
  3. Press Enter.

Result: Default button gets pressed (even though it was not highlighted).

Expected result: Highlighted button gets pressed.

Attachments (2)

Change History (8)

comment:1 by KapiX, 5 years ago

I have found where the problem is, I will provide patch when I will test it.

comment:2 by KapiX, 5 years ago

Has a Patch: set

comment:3 by jessicah, 5 years ago

Resolution: fixed
Status: newclosed

Applied in hrev47179

comment:4 by KapiX, 5 years ago

Resolution: fixed
Status: closedreopened

comment:5 by KapiX, 5 years ago

I don't mind if this change gets reverted (as there is some opposition on the mailing lists), I just made the patch before I realized that's how it is supposed to work.

comment:6 by pulkomandy, 5 years ago

Resolution: no change required
Status: reopenedclosed

The change was reverted, I think the current behavior is ok as you can invoke other controls with space, making enter effectively a "validate window" action (just as escape is "abort and close window").

Note: See TracTickets for help on using tickets.