Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10879 closed bug (fixed)

[Pe] won't lookup system headers any more.

Reported by: ttcoder Owned by: zooey
Priority: normal Milestone: R1/beta1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

For as long as I remember I could Alt-D and type e.g. View.h in the pop-up requester and that would open the header file for the BView class ..etc. But there is now a (very) annoying regression.

It doesn't work on both recent Haiku installs I have here. Might have regressed recently or a long time ago, not sure: I'm only migrating my coding to PM "for real" since a few weeks ago.

Change History (9)

comment:1 by ttcoder, 5 years ago

I tried wiping out config/settings/pe but that doesn't fix the situation.

The $BEINCLUDES variable certainly seems to have migrated post-PM correctly:

~/Desktop> echo $BEINCLUDES 
/boot/system/develop/headers;/boot/system/develop/headers/be;/boot/system/develop/headers/posix;/boot/system/develop/headers/glibc;/boot/system/develop/headers/cpp;/boot/system/develop/headers/be/app;/boot/system/develop/headers/be/device;/boot/system/develop/headers/be/interface;/boot/system/develop/headers/be/locale;/boot/system/develop/headers/be/media;/boot/system/develop/headers/be/midi;/boot/system/develop/headers/be/midi2;/boot/system/develop/headers/be/net;/boot/system/develop/headers/be/kernel;/boot/system/develop/headers/be/storage;/boot/system/develop/headers/be/support;/boot/system/develop/headers/be/game;/boot/system/develop/headers/be/opengl;/boot/system/develop/headers/be/drivers;/boot/system/develop/headers/gnu;/boot/system/develop/headers/be/mail;/boot/system/develop/headers/be/translation;/boot/system/develop/headers/be/devel;/boot/system/develop/headers/be/add-ons/graphics;/boot/system/develop/headers/be/be_apps/Deskbar;/boot/system/develop/headers/be/be_apps/NetPositive;/boot/system/develop/headers/be/be_apps/Tracker

So I'm not sure why Pe would no longer work..

Also tried looking up the 'tickets' page over at http://developer.berlios.de/projects/pe-editor/ but the ticket interface is nowhere to be found; I'm pretty sure I had seen one there a few months ago, strange..

Last edited 5 years ago by ttcoder (previous) (diff)

comment:2 by diver, 5 years ago

I think Pe has moved over to github. See https://github.com/olta/pe/issues

comment:3 by ttcoder, 5 years ago

Thanks much diver! Filed issue 9 over there: https://github.com/olta/pe/issues/9

I hope Oliver will update the various berlios ..etc pages (and martin over at hekkelman.com) to mention the new repo, duckduckgo.com knows nothing about github/pe it seems so it's hard to find..

comment:4 by anevilyak, 5 years ago

Owner: changed from nobody to zooey
Priority: highnormal
Status: newassigned

comment:5 by waddlesplash, 5 years ago

Milestone: R1R1/alpha5

comment:6 by zooey, 5 years ago

Status: assignedin-progress

comment:7 by ttcoder, 5 years ago

github issue 9 https://github.com/olta/pe/issues/9 closed as fixed. Will pkgman upin a few days to retrieve it. Thanks!

comment:8 by zooey, 5 years ago

Resolution: fixed
Status: in-progressclosed

The problem was that Pe stopped looking any further when it encountered a non-existing path in BEINCLUDES. That's fixed now and the resulting Pe packages are included starting with hrev47286.

comment:9 by pulkomandy, 5 years ago

Milestone: R1/alpha5R1/beta1
Note: See TracTickets for help on using tickets.