Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#10879 closed bug (fixed)

[Pe] won't lookup system headers any more.

Reported by: ttcoder Owned by: zooey
Priority: normal Milestone: R1/beta1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All


For as long as I remember I could Alt-D and type e.g. View.h in the pop-up requester and that would open the header file for the BView class ..etc. But there is now a (very) annoying regression.

It doesn't work on both recent Haiku installs I have here. Might have regressed recently or a long time ago, not sure: I'm only migrating my coding to PM "for real" since a few weeks ago.

Change History (9)

comment:1 by ttcoder, 7 years ago

I tried wiping out config/settings/pe but that doesn't fix the situation.

The $BEINCLUDE variable certainly seems to have migrated post-PM correctly:

~/Desktop> echo $BEINCLUDES 

So I'm not sure why Pe would no longer work..

Also tried looking up the 'tickets' page over at but the ticket interface is nowhere to be found; I'm pretty sure I had seen one there a few months ago, strange..

Version 1, edited 7 years ago by ttcoder (previous) (next) (diff)

comment:2 by diver, 7 years ago

I think Pe has moved over to github. See

comment:3 by ttcoder, 7 years ago

Thanks much diver! Filed issue 9 over there:

I hope Oliver will update the various berlios ..etc pages (and martin over at to mention the new repo, knows nothing about github/pe it seems so it's hard to find..

comment:4 by anevilyak, 7 years ago

Owner: changed from nobody to zooey
Priority: highnormal
Status: newassigned

comment:5 by waddlesplash, 7 years ago

Milestone: R1R1/alpha5

comment:6 by zooey, 7 years ago

Status: assignedin-progress

comment:7 by ttcoder, 7 years ago

github issue 9 closed as fixed. Will pkgman upin a few days to retrieve it. Thanks!

comment:8 by zooey, 7 years ago

Resolution: fixed
Status: in-progressclosed

The problem was that Pe stopped looking any further when it encountered a non-existing path in BEINCLUDES. That's fixed now and the resulting Pe packages are included starting with hrev47286.

comment:9 by pulkomandy, 6 years ago

Milestone: R1/alpha5R1/beta1
Note: See TracTickets for help on using tickets.