Opened 5 years ago

Closed 5 years ago

#10947 closed bug (invalid)

Problem creating new partitions in DriveSetup

Reported by: kallisti5 Owned by: stippi
Priority: blocker Milestone: R1/beta1
Component: Applications/DriveSetup Version: R1/Development
Keywords: Cc: starsseed@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

As of hrev47345, gcc4h you are unable to create a new partition.

Steps to reproduce:

  • Open DriveSetup after booting ISO
  • Create a new Intel partition map on an empty disk
  • Partition -> Create remains disabled.

As this would impact new installs, i'm setting this one to Alpha 5 with a blocker status.

Attachments (3)

1.png (51.7 KB) - added by kallisti5 5 years ago.
create new intel partition map
2.png (50.7 KB) - added by kallisti5 5 years ago.
create new partition disabled
drivesetup.png (69.4 KB) - added by jua 5 years ago.
drivesetup hrev47380

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by kallisti5

Attachment: 1.png added

create new intel partition map

Changed 5 years ago by kallisti5

Attachment: 2.png added

create new partition disabled

comment:1 Changed 5 years ago by kallisti5

recent drivesetup changes: http://cgit.haiku-os.org/haiku/log/src/apps/drivesetup

recent intel disk system changes: http://cgit.haiku-os.org/haiku/log/src/add-ons/disk_systems/intel

recent kernel add-on changes: http://cgit.haiku-os.org/haiku/log/src/add-ons/kernel

The recent drivesetup changes seem like the most suspect based on timing alone.

comment:2 Changed 5 years ago by starsseed

Cc: starsseed@… added

possibly duplicate #7930

comment:3 Changed 5 years ago by jua

From the screenshots, it seems it already fails at creating the partition map. If that works correctly, it shows a "<empty>" entry on the disk, when you select that, create partitions is enabled (see screenshot below).

Unfortunately I can't reproduce it here, with hrev47380 in virtualbox, it works fine... could you use a current hrev and only replace the DriveSetup binary in it with one before the recent changes and try it with that?

Changed 5 years ago by jua

Attachment: drivesetup.png added

drivesetup hrev47380

comment:4 Changed 5 years ago by pulkomandy

There are at least two problems here:

  • The intel partition map not willing to create a partition map (possibly it detected something else on the disk?)
  • Complete lack of error reporting in DriveSetup, so we have no idea what really happened.

comment:5 Changed 5 years ago by pulkomandy

Summary: Problem creating creating new partitions in DriveSetupProblem creating new partitions in DriveSetup

comment:6 Changed 5 years ago by pulkomandy

Milestone: R1/alpha5R1/beta1

comment:7 Changed 5 years ago by kallisti5

Resolution: invalid
Status: newclosed

I have a feeling this is a duplicate of #8823. If the disk contains a GPT backup map at the end of the disk, you are unable to create a new MBR table or partitions as the GPT add-on attemps to load as well.

Note: See TracTickets for help on using tickets.