Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10956 closed bug (fixed)

Missing guide pages on haiku-os.org

Reported by: pulkomandy Owned by: haiku-web
Priority: critical Milestone:
Component: Website/CMS Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The following pages disappeared from the website:

Can they be restored?

Change History (9)

comment:1 Changed 5 years ago by arfonzo

It may be more than just these two pages, perhaps everything under the guides section.

comment:2 Changed 5 years ago by kallisti5

we're worried about compromise or disk corruption at this point. I saw lots of spammers creating accounts this morning, and we noticed some disk / malloc errors in dmesg:

[286510.697200] systemd-journald[271]: Failed to write entry (20 items, 701 bytes), ignoring: Cannot allocate memory
[289388.892195] ata1.00: failed command: WRITE DMA

Nielx is looking at it in a few mins.

comment:3 Changed 5 years ago by kallisti5

I rebuilt the guide index page by recreating it from archive.org, but the paths still existed pointing to the old node id.

I fixed that, but all the book pages also still point to the old node ID:

Old: http://www.haiku-os.org/node/3226 (missing?!)

Recreated: https://www.haiku-os.org/node/6067

comment:4 Changed 5 years ago by nielx

Update: the reason why the pages have disappeared has been found. The user id had been set to the value 0, which is not a valid user.

The cause is not known.

Currently we are trying to restore the correct user ids from a backup.

comment:5 in reply to:  4 Changed 5 years ago by jprostko

Replying to nielx:

Update: the reason why the pages have disappeared has been found. The user id had been set to the value 0, which is not a valid user.

The cause is not known.

Currently we are trying to restore the correct user ids from a backup.

Technically, UID 0 is used for the anonymous user role, and appears as the first entry in the users table. I suspect you know that already though, and were just trying to keep the explanation simple. :) It's weird that valid uids for authenticated users were replaced by the anonymous user id somehow. Hopefully you find out the root cause soon enough after the problem is corrected.

comment:6 Changed 5 years ago by nielx

Actually that is very useful information. Are you sure it exists in the user table? Because currently it doesn't (which explains why suddenly the pages would stop working).

comment:7 Changed 5 years ago by nielx

Note to self: see https://drupal.org/node/1029506 on how to restore the user.

comment:8 Changed 5 years ago by nielx

Resolution: fixed
Status: newclosed

Thanks jprostko, that probably fixes the issue for good.

Still no explanation on the cause (how got the anonymous user deleted?) but at least for the future we will not run into unexpected problems.

comment:9 Changed 5 years ago by jprostko

Hey, sorry I'm slow on the response here. I was going to suggest that maybe the anonymous role accidentally got deleted, but your mention of restoring the uids from the backup made me think they were actually associated with uids greater than 0.

In any case, I am glad to know you got it fixed!

Note: See TracTickets for help on using tickets.